
The OmniVista User Interface 

The OmniVista User Interface 
This section gives an overview of OmniVista's user interface. It points out the elements and functionality 
that are common to most OmniVista applications. It explains the various ways to open and close 
applications, how to access status and notifications information, how to customize your view, and how to 
use OmniVista's help system. 

The following example, taken from the Topology application, shows some of the window elements that are 
common to most OmniVista applications. 

 

The layout and contents of the main application window will vary, depending on the requirements of the 
particular application. You may see tables, graphs, network diagrams, configurations screens, etc. 

The tree control is a means of accessing other windows in the application. Applications with only one 
window normally do not have a tree control. 

The application tray shows each of the applications running in the current window. The application 
highlighted in dark gray is the one which is currently active and visible. The other applications are running 
in the background. To view a different application, click on its icon in the application tray. 
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Using the Tool Bar 

Using the Tool Bar 

 

The tool bar includes the following tool icons: 

  Hide/Show the Task Bar. 

  
Hide/Show the Tree Control. If an application does not make use of a tree control, this 
button will be disabled. 

  Hide/Show the Status Panel 

  
Hide/Show the Tool Bar. Once you hide the tool bar, the only way to redisplay it is to 
uncheck the Hide Tool Bar option on the View Menu. 

  Right size tree panel. Extends the tree panel width to accommodate the longest line of text. 

  
Show previous task in Browse History. When an action in one application causes a second 
application to display and become active, the Forward button in the second application 
becomes enabled. Click the Back button to return to the previous application. 

  
Show next task in Browse History. After using the Back button, the Forward button 
becomes enabled. Click the Forward button to return to wherever you were previously. 

  
Stop/Start polling. To disable polling, click on the green icon. To enable polling, click on 
the red icon. 

  Close the current application. 

In some applications a secondary toolbar displays inside the main application window. Icons for that 
toolbar include: 

  
Select Filter. Opens the Filter Selection Dialog. For more information, see the Filters 
help. 

  
Apply Filter/Disable Filter. Click the green icon to apply the selected filter. Click the red 
icon to disable the filter. For more information, see the Filters help. 
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Using the Toolbar 

  
Resize table columns. Expands each column to a size large enough to show the longest 
line of text. 

 

Select display area. When an application window contains an upper and lower window 

pane, click  to hide the lower pane and expand the upper pane. Click  to re-
display the lower pane. 

 
Print Table. Prints the title of the table and the table headers of the columns as displayed. 
You can either shrink the table to fit the width of a page or print across as many pages as 
it takes to print all columns. 

 
Select Device using Groups. Selects groups of devices using one or more Physical or 
Logical (user-defined) maps.  
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View Menu 

View Menu 

 

Use the check boxes in the View Menu to hide or display the Task Bar, Tree Control, Status Panel, or Tool 
Bar. A checked box indicates that the item is displayed. An unchecked box means that the item is hidden. If 
the box is grayed out, then the item is not available for the current application. 

Select the Tasks... menu option to display the Tasks window. For details, see Closing Applications, "Using 
the Tasks Window." 

Select the Devices By menu option to view devices by IP address, name, both the IP address and the name, 
DNS, or both the DNS and the IP address. The Devices By menu option appears only for applications that 
include a device tree control (For example, Topology and Notifications both use a tree control.).  
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Launching Applications 

Launching Applications 
To launch an application, use either the Task bar, or the Applications menu, or the right-click menu options 
in the Task bar. 

Task Bar 

The Task bar displays a number of application groups, with each group containing one or more 
applications. 

To launch an application, click the corresponding application group, and then click the desired application. 

 

Applications Menu 

You can also launch applications from the Applications menu. 

 

From the Applications menu, point to an application group, and then select an application from the 
submenu. 
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Launching Applications 

Right-Click Menu Options 

You can open as many applications as you want in a single window. However, only one application is 
displayed at a time. While the current application is displayed, the other applications continue to run in the 
background. To display a different application, click the corresponding button in the application tray. 
Instead of running all your applications in a single window, you can use multiple windows.  

To open an application in a new or current window, right-click the desired application in the task bar. A 
pop-up menu is displayed as shown below. To open the application in a new window, click Run in new 
Window. To open the application in the current window, click Run in current Window. 
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Closing Applications 

Closing Applications 
There are several ways to close an application. These include: 

• File > Close [Application]  
• File > Close Window  
• File > Exit  
• Using the "close application" icon  
• Using the "application tray"  
• Using the Tasks Window  

See below for a description of each method. 

File > Close [Application] 

 

Select File > Close [Application] to close the current application. Any other applications running in the 
same window will remain open. If there is only one application running in the window at the time you 
select File > Close [Application], the application closes, but the window remains open with just the 
OmniVista splash screen displayed. 

File > Close Window 

 

Select File > Close Window to close the current window and to close all applications running in that 
window. Any other windows remain open. 
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Closing Applications 

File > Exit 

 

Select File > Exit to close all applications running in all windows, and to exit the OmniVista program. 

Using the Close Application Icon 

Use the Close Application icon to close the current active application only. This is the same as 
selecting File > Close [Application]. 

Using the Application Tray 

In the application tray, right-click on the name of the application you want to close. When the pop-up menu 
displays, click Close. 

 

This is the same as selecting File > Close [Application] or clicking the Close Application icon . 
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Closing Applications 

Using the Tasks Window 

Use the Tasks Window to terminate an application immediately. To access this window, select View > 
Tasks. Select a row in the table, then click End Task. 

 

The Tasks Window is useful when the network is busy and closing an application using one of the other 
methods would take much longer. 
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Viewing Status Information 

Viewing Status Information 
Status information can be found in the Status & Notifications Pane, and also in the Status Bar (see the 
illustration below). 

 

The Status and Notifications Pane 

The Status & Notifications Pane displays either status information or trap notifications, depending on 
whether the Status Tab or the Notifications Tab is selected. The information displayed is for all OmniVista 
applications, and not just the current active application. This makes status and notifications information 
available at all times, from any application. For example, if you want to see a list of notifications, you do 
not need to be in the Notifications application; you can see the information while working from Topology, 
or Statistics, or any other application. The same is true for status information. 

If the Status & Notifications Pane is not currently visible, select View > Status Panel from the toolbar. A 
checked box indicates that the Status & Notifications Pane is displayed. An unchecked box indicates that 
the window pane is hidden. You can also hide or display the Status & Notifications pane by clicking on the 
show/hide controls . 
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Viewing Status Information 

Status Tab 

When the Status Tab is selected, the Status & Notifications pane shows information on current user 
activity. In the example below, the user has made a request to connect to switch 10.255.11.109 , and the 
Topology application has responded by sending an informational message indicating that a connection is 
currently in progress. 

 

Status messages display from the time the user last logged into OmniVista. Possible types of messages 
include: autodiscovery status, success or failure when attempting to connect to a switch, and status when 
initializing data. 

Status messages can be sorted by clicking in any of the column headings. 

Status messages can be copied to the clipboard, then pasted into a text processor or spreadsheet. To copy 
status information, select one or more rows from the Status table, then right-click to bring up the pop-up 
menu. When the pop-up menu appears, click Copy. 

Status messages can also be cleared from the table. Select the rows you want to remove, right-click to bring 
up the pop-up menu, then select Clear. 

Notifications Tab 

When the Notifications Tab is selected, the Status & Notifications pane shows a list of notifications from 
all switches configured to send trap notifications to the OmniVista server. This is the same list that displays 
through the Notifications application when the Switches node is selected. (For information on how to 
configure switches to send trap notifications, see the Configure Traps help.) 
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Viewing Status Information 

The last, or most recent, trap received is displayed at the bottom of the table. Notifications display in the 
color representing their severity level. Color values are as follows: 

 Severity Level Color 

Normal Blue 

Warning Green 

Minor Magenta 

Major Yellow 

Critical Red 

Acknowledging a trap and renouncing an acknowledgement works the same from both the Notifications 
application and the Status and Notifications Pane. Select one or more rows in the Notifications table, then 
right-click to display the pop-up menu. Click on Acknowledge, Renounce Acknowledgement, or Resize 
Columns. 

 

When notifications are first received, they display in bold type. After you acknowledge a notification, it 
changes to plain type. If you renounce an acknowledgement, it changes back to bold type. 

Notifications can be sorted by clicking in any column heading. For example, click in the column heading 
"Acknowledged" to see trap notifications grouped as acknowledged ("true") or not yet acknowledged 
("false"). Generally, you would acknowledge a notification after you have reviewed it, taken any necessary 
action, and no longer need to have it flagged. Acknowledging a trap notification does not in any way affect 
the display of the Trap Notification icon ( ). The Trap Notification icon remains displayed until you left-
click on any row in the Notifications table (for details, see the Trap Notification Icon discussion below). 

Notifications cannot be copied or cleared from the Status & Notifications Pane. Those options are available 
through the pop-up menu in the Notifications application, but not the pop-up menu in the Status & 
Notifications Pane. 

The Status Bar 

The Status Bar shows session status information, as opposed to the Status Tab in the Status & Notifications 
Pane, which shows application status. 

The left-hand side of the Status Bar shows the current application, the active user, and the server name or 
server IP address. In the following example, Topology is the current application, admin is the active user, 
and the IP address of the server is displayed. 
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Viewing Status Information 

 

On the right-hand side of the Status Bar in the example above are a Secure Socket Layer (SSL) status icon, 
five polling cycle indicators, and two status indicators and : 

The SSL Status Icon displays when the current server connection is using SSL, 
which can be set at installation time or by using the Preferences application. No icon is 
displayed when you are not logged in or you are logged into a server without using SSL. 

The Polling Cycle Indicators show when regular polling cycles are invoked. 
These five indicators are described below, where square brackets with an "X" ("[X]") 
indicates the light is on and square brackets without an "X" ("[]") indicate the light is off: 

 [] [] [] [] []  No poll in progress 
 [X] [] [] [] []   "Down Switch" poll in progress 
 [X] [X] [] [] []   "Frequently" poll in progress 
 [X] [X] [X] [] []  "Regularly" poll in progress 
 [X] [X] [X] [X] []   "Rarely" poll in progress  
 [X] [X] [X] [X] [X]  "Auto-Discovery" poll in progress 

 

The Status Indicator Light shows the status of the current data request. Color states 
are as follows: 

Green Request for data successfully completed. 

Yellow Request for data in progress. 

Red Request for data failed. 

The Notifications Receive Indicator displays whenever the server receives a new 
trap. To dismiss the icon, left-click on any row in the Notifications table (you can do this 
from either the Notifications application or the Status & Notifications Pane). 
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Selecting Switches 

Selecting Switches 
Certain applications require that you select one or more switches before you can begin using that 
application, or before you can begin using a particular function within that application. In general, there are 
two ways to select switches, either from a switch table (such as the "All Discovered Devices" table in 
Topology or the "Select Devices" table in Health), or from a switch tree. 

Selecting Switches from a Table 

When selecting switches from a table, the Shift and Ctrl keys can be used to select multiple switches. After 
selecting switches, you can usually right-click to bring up a pop-menu, from which you can select an action 
to apply to the switch or switches. For example, from the Topology pop-up menu you can Edit, Remove, 
Poll, or create a switch Inventory for the selected switches. 

In general, when you select multiple switches, this results in the switches being pre-selected and displayed 
in some other area. The following examples from Health and Topology illustrate. 

Example 1 

As soon as you launch the Health application, the Select Devices window displays, prompting you to select 
one or more switches for which you want to view health information. 

 

After you make your selections, the switches appear in the List Pane as pre-selected items (see the below 
illustration). If you do not pre-select the switches, you will need to add them manually later on. 
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Selecting Switches 

 

Example 2 

Select multiple switches from the "All Discovered Devices" table, then launch the Configure Traps wizard 

. 

 

The switches will be displayed as pre-selected items in the Configure Traps window. 
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Selecting Switches 

 

 

Selecting Switches from the Switch Tree 

When using the switch tree, you can only select one switch at a time. You cannot select multiple switches, 
as you can using the switch table. Right-clicking on a switch in the switch tree will also bring up a pop-up 
menu. 
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Using Multiple Windows 

Using Multiple Windows 
You can run multiple applications in a single window or in multiple windows. 

Running applications in a single window 

You can open as many applications as you want in a single window. However, only one application 
displays at a time. While the current application is displayed, the others continue to run in the background. 
To display a different application, simply click on its icon in the application tray. 
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Using Multiple Windows 

Running applications in multiple windows 

Instead of running all your applications in a single window, you can use multiple windows. To open an 
application in a new window, right-click on its icon in the taskbar. When the pop-up menu appears, select 
Run in new Window. 

 

 

You can have as many windows open as you like. When more than one window is open, you can switch 
back and forth between applications by clicking on a different window. 

 

 

18 



Setting Preferences 

Setting Preferences 
Preferences are displayed and configured in the Preferences application, which is shown below. See the 
online help for Preferences for more information. 
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Sorting Data 

Sorting Data 
Use the Sort button to sort information in a table. The Sort button is not displayed by default. To display 
the Sort button, click in the column header you want to sort by. 

 

Click once to sort in ascending alphanumeric order. Click again to sort in descending order. 
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Using the Help System 

Using the Help System 
Accessing Help 

There are two ways to access help information. You can access help through the menubar, or you can click 
on the Help button in an application window. 

Using the Help menu, you can select help for all of OmniVista (Help > OmniVista 2500 Help), or you can 
select help for the current application only (Help > [Application Name] Help, e.g., Topology Help). 

When the Help button is used, OmniVista displays screen-level context-sensitive help. This means that 
the help information is specific to your current screen location. 

Finding Information 

Table of Contents 

To see a list of help topics, click on the Table of Contents tab . Find the topic that interests you, then 
view the information through the adjacent window. If the help page contains a large or complicated 
graphic, it may take a few seconds for the page to display. 
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Using the Help System 
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Search Tool 

To find a word or topic quickly, use the Search tool. To learn how to use the Search tool, follow the 
numbered steps in the example below. 

 

When a phrase of two or more words is entered, the Search tool finds all instances of that phrase, as well as 
all instances of each word in that phrase. 

The probability index shows the likelihood that the desired match was found. A filled circle represents a 
higher probability than a partially filled circle . 
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