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Mitel Networks™ 6120 CCS (Contact Center Scheduling) consists of 6120 CCS Administrator and 
6120 CCS (Call Center Edition).

You must first configured your network security requirements with the Administrator. Please see the 
Mitel Networks 6120 Contact Center Schedule Installation Guide for setup instructions.

Then, with the 6120 CCS Call Center Edition you can schedule your employees to best suit your call 
center needs: 
•    You can customize schedules and groups. 
•    You can match an employees skills to those skills required for each schedule.
•    You can easily view the distribution of employees across each shift. 
•    You can print schedule reports. 

When you start 6120 CCS Call Center Edition, Figure 1 appears.
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You can customize schedules and groups with the Options window. It consists of eight tabs you use to 
specify schedule parameters: General, Shifts, Jobs, Time-off, Overtime, Schedule Builder, Holidays, and 
Organization.

����������	
When you click Tools=>Options, Figure 2 appears.

On the General tab, you can create filters to assist in searching for employees, and specify 6120 CCS 
display attributes. 
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To add a schedule name:
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To edit a schedule name:
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To delete a schedule name:
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To enable user-defined fields:
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To disable user-defined fields:
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To enable filters:
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To disable filters:
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To set the time formats:
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To set the first day of the work week:
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To set the daily start time:
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To set the time bar content display:
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To set the time bar display scale:
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To set the snap-to-grid display scale:
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To display photos of employees:
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To automatically redraw time bars:

������"���,����������-.��������
������%���,������	����������	
��
������-�������	�	���(����)����������������	������3��

The time bars will be automatically redrawn whenever changes are made to the Schedules window. 
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When you click Tools=>Options and click the Shifts tab, Figure 3 appears.

On the Shifts tab, you can add shift types, then specify shift attributes and warnings.
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To add a shift type:

������"���,����������-.��������
������%���,������	����"�������
���������(�������"���#���0������������!�1�
�����
����������'1!���������
����	���	�
��������������

To edit a shift type:
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To delete a shift type:
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To set the total work hours:
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In the Total Work Hours group, set the daily, weekly, and monthly total hours for a typical, minimum, and 
maximum shift. 
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To add a break:
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To edit a break:
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To delete a break:
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Shift warnings consist of Exceeds Daily Maximum Work Hours, Exceeds Weekly Maximum Hours, and 
Below Daily Minimum Hours.

To set shift warnings:
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Setting break warnings consist of Hour to Qualify, Start Time Violation, and End Time Violation.
To set break warnings:
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When you click Tools=>Options and click the Jobs tab, Figure 4 appears.

On the Jobs tab, you can specify jobs and job attributes.
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To add a job:
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To edit a job:
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 To delete a job:
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To set a job warning:
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When you click Tools=>Options, and click the Time-off tab, Figure 5 appears.

On the Time-off tab, you specify time-off types and attributes.
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To add a time-off type:

������"���,����������-.��������
������%���,������	������&�""�����
���������(���������&�""��#���0������������!�1�
�����
����������'1!���������
����	��������

��1!��������������
������������������	��(��������	������3�����!���
1�����������1�
������������	�����
������������������	��'�����	������3�����!���
1�����������1�
���!�1�����
������5�����������	��(��� �#��	������3�����!���
1��
��	���1!���
�������

����������
�������������

��1�



"%�����"%&���	��������(����)����
To edit a time-off:
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To delete a time-off:
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To set the length of service required to qualify for a time-off:
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To set the accruing time-off hours:
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To set time-off warnings:
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To set time-off scheduling limits:
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When you click Tools=>Options and click the Overtime tab, Figure 6 appears.

On the Overtime tab, you can specify overtime compensation for shifts.
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To set the overtime pay rate:
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To reset the overtime pay rate setting to the default:
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When you click Tools=>Options Window and click the ScheduleBuilder tab, Figure 7 appears.

On the ScheduleBuilder tab, you can prioritize the criteria used to create schedules, and specify automated 
scheduling parameters.
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To set automatic scheduling for shifts:
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To add a personal priority number:
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To edit a personal priority number:
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To set automatic scheduling for breaks:
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When you click Tools=>Options Window and click the Holidays tab Figure 8 appears.

On the Holidays tab, you can specify holidays and view them.
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To add a holiday:
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To edit a holiday:
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To delete a holiday:
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When you click Tools=>Options Window and click the Organization tab, Figure 9 appears.

On the Organization tab, you can specify company contact information, and company departments and job 
titles.
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To change company information:
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To add a department:
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 To edit a department:
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To delete a department:

NOTE: Deleting a department deletes all of the employees in the department.
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To add a job title:

������"���,����������-.��������
������%���,������	��������<����������
���������(�����������0������������!�1�����������1!���������
����	��������

To edit a job title:
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To delete a job title:
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You can add your employees information and skills with the People Window. Information includes: 
identification, address, payroll, and vacation information. Skills include: a language such as Spanish or 
French, a degree, or experience. These skills can then be matched with skills required for each job.

When you click Window=>People Window, Figure 10 appears.
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You can add people to 6120 CCS from the People window or the Scheduler window.

To add a person on the People window:
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Specify a first and last name, department, title, shift type, supervisor, business phone number, extension 
number, fax number, and e-mail address for the person.
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 To add a person on the People window:
����������,�����=�����-.'������
Specify a first and last name, department, title, shift type, supervisor, business phone number, extension 
number, fax number, and e-mail address for the person.
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On the General tab, you add identification information for people.
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To change employee information:
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To add a photo:
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To locate a person in the People window:
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6120 CCS highlights the person’s name in the Last Name column. 
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 When you click Window=>People Window and click the Address tab, Figure 11 appears.

On the Address tab, you add addresses for people.
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To add an address:
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When you click Window=>People Window and click the Personal tab, Figure 12 appears.

On the Personal tab, you add payroll and emergency contact information for people. 
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To add personal information:
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When you click Window=>People Window and click the Notes tab, Figure 13 appears.

On the Notes tab, you add notes for people.
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To add notes for a person:
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When you click Window=>People Window and click the Time-off tab, Figure 14 appears.

On the Time-off tab, you specify time-off types and attributes.
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To review a person’s time-off balance:
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When you click Window=>People Window and click the Skills tab, Figure 15 appears.

On the Skills tab, you specify employees skills.

��������3�'��������������%��������

�

�����������$��,���%��
To add an employee’s skills:
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The skill will appear in the Selected Skills list. 
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When you click Edit=>Find, Figure 16 appears.

The Find window consists of three tabs you can use to search for schedules, people, and jobs.
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On the Schedules tab, you can search for daily or weekly schedules for a particular date range.
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To find a schedule:
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 6120 CCS displays the schedules for the time period selected. 
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When you click Edit=>Find and click the People tab, Figure 17 appears.

On the People tab, you can search for people for a particular date range.
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To find a person:
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When you click Edit=>Find and click the Notes tab, Figure 18 appears.
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On the Notes tab, you can search for notes associated to shifts or jobs scheduled for a particular date range.
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To find a note:
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You can create the schedule with the Scheduler Window. You can adjust the shift or break times for people, 
and view the people forecast, scheduled, over/under, available, or on break.

When you click Window=>Scheduler Window, Figure 19 appears.
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To view an event:
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Event types consist of Shifts, Jobs, Breaks, Time-off, and Unavailable.
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To add a shift:
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 The Insert Shift screen appears.
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The shift you added to the time bar display is added automatically to the Schedules table.
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To add a job:
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The Insert Job screen appears. If there are no jobs listed in the table, on the Options window under Jobs, 
define one or more job types.
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 The job you added to the shift time bar is added automatically to the Schedules table.
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To add a break:
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The Insert Break screen appears. If there are no breaks listed in the table, on the Options window under 
Shifts, define one or more break types.
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The break you added to the time bar display is added automatically to the Schedules table.
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To add a time-off:
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The Insert Time-off screen appears. If there are no Time-offs listed in the table, on the Options window 
under Time-off, define one or more time-off types.
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On the time bar display, adjacent to the name of the person who needs a time-off, click the start time for the 
time-off and drag the time bar to the desired time-off end time.

 The time-off you added to the time bar display is added automatically to the Schedules table.
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To add an unavailable:
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The Insert Unavailable screen appears.
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The unavailable you added to the time bar display is added automatically to the Schedules table.
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To move a time bar:
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Any changes you make to the time bar display are duplicated automatically in the Schedules table.

�	�����������������	���������������
To shorten or lengthen a time bar:
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 The cursor changes from a four-headed arrow to a double-headed arrow.
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To edit an event on the Schedules table:
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You can make a shift recur weekly, monthly, or yearly. In this example we will schedule a shift to recur 
daily.

 To make a shift recur daily:
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The Recurring dialog box opens. Under This occurs, Daily is selected. The days the shift will recur are 
highlighted in blue on the Recurring Dates calendar.

You can change the start and end times for a shift. You can specify how frequently the shift will recur, such 
as every day or every second day, and specify the date range over which the shift will recur.
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To delete an event:
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To find a schedule or shift:
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The Find dialog box appears.
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To lock a shift:
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Using filters, you can quickly locate people to display on the time bar and the Schedules table. A filter 
works likes a sieve, narrowing down your search for people.

You use filters in the Schedules, People, and Reports windows. You can enable up to four filters and create 
custom filters using user-defined fields.
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To change the time period viewed on the Schedules window time bar display:
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To change a person’s shift assignment on the Schedules window:

������"���*���	��������������!��10��������	���	�
������������������	������
������%���,����������-.������-.'������
���������/���	��(�������������0��������	��!���������+	��	�1���+������������	���	�
��
����������,������2��

�����������������+������
�������������
To change a person’s schedule assignment on the Schedules window:
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To change a person’s shift type on the Schedules window:
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To add columns to the Schedules table:
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The Custom Columns screen appears.
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To remove columns from the Schedules table:
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To set schedule totals on the Schedules window:
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The View Totals screen appears.
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To sort events:
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6120 CCS displays the time bars and corresponding time cells in the order selected.
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To view people totals on the Schedules window:
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To update the time-off parameter:
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To edit the time-off parameter:
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You can create and view the proposed schedule with the Forecast Window.

When you click Window=>Forecast Window, Figure 20 appears.
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To create a schedule forecast:
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When you expand the tree, 6120 CCS displays departments, working groups, and employee titles.



�&�����"%&���	��������(����)����
����������,����������!��1��������0����	����?�����1�����������>�!�

The Forecast chart displays the number of quality assurance representatives forecast across one hour time 
intervals for the day.
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6120 CCS saves any changes you make instantly. 



>�!�����+����+�����"
#����������
��
You can select a report and print, e-mail, or export it with the Reports window. Reports access is assigned 
with the Administrator. 

When you click File=>Print Figure 21 appears.
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On the print tab, you can print report information.
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      •    Click Print.
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On the Email tab, you can e-mail report information.

 "��������������
To e-mail a report:
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NOTE: Only scheduled reports and budget reports have a date range option.
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On the Export tab, you can export report information.
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To export a report:
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NOTE:  Only scheduled reports and budget reports have a date range option.
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To back up the database:
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We recommend you back up 6120 CCS whenever you make major changes.

To restore the database:
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The 6120 CCS Restore screen appears.

����������,������2�

The Confirm Restore screen appears.

NOTE: The restoration procedure overwrites all existing information in 6120 CCS.
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To compact the database:
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The Compact Database screen appears.
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To create a schedule, you must follow these steps:
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The following exercise will familiarize you with 6120 CCS.

To create an automatic schedule, you must follow these steps:
•    Name a schedule.
•    Create the work week.
•    Create a shift.
•    Describe the organization of your company.
•    Add job skills.
•    Add general employee information.
•    Assign an employee a department, workgroup, and title.
•    Add employee skills.
•    Create an automatic schedule.


�������
In this scenario, you will create a schedule for the first shift of the day, and add one person to that schedule.

You run a travel agency. Your office is open from 7:00 A.M. until 7:00 P.M. Monday is the first day of the 
week, and your office is open five days a week. The first shift occurs daily from 7:00 A.M. until 3:00 P.M. 
The employees get a 15-minute break in the morning and again in the afternoon. These breaks are paid. 
Their lunch is 30 minutes, and is not paid.

You will add John Smith to the Early Shift. He is a domestic bilingual travel agent. He speaks English and 
Spanish. He works full time.
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When you click Tools=>Options Window, the General tab appears. (See Figure 29.)
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The Options window, Shifts tab appears. (See Figure 30.)
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Note: The Total Work Hours are the number of hours for which the employee is paid. When John Smith 
works from 7:00 A.M. until 3:00 P.M., and has a half-hour lunch, he is paid for only 7.5 hours. 
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The Options window, Organization tab appears. (See Figure 31.)
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The Options window, Organization tab appears for Sales. (See Figure 32.)
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The Options window, Organization tab appears for Accounting. (See Figure 33.)
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The Options window, Organization tab appears for Technical Support. (See Figure 34.)
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The Options window, Skills tab appears. (See Figure 35.)
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These are employee skills necessary to get the job done. For example, you may need some employees to 
serve customers in Spanish.
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The skill Spanish appears in the Skill List.
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John Smith is a domestic bilingual travel agent. He speaks English and Spanish. He works full time.
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The People window, General tab appears. (See Figure 36.)
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Figure 37 shows the People window, General tab.
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The skills that you entered in the Option window, on the Skills tab, are displayed in the Available Skills list. 
You entered Spanish as a skill. John Smith is a bilingual travel agent, so his skill is Spanish.
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The People window, Skills tab appears. (See Figure 38.)
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The skill appears in the Selected Skills list.
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The window closes.
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The ScheduleBuilder window appears. (See Figure 39.)
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A Schedule Builder Session Summary appears. When the rate per hour has been input in the Jobs box of the 
Options window, the summary indicates the budget spent on staff. 
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A green time bar spanning the shift hours appears next to an employee’s name. (See Figure 40.)
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The breaks appear on the green time bar. (See Figure 41.)
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You can change users permissions even after 6120 CCS has been setup and is running. Administrator 
controls which information particular users can use over the network.

Administrator consists of five tabs: Users, Permission, Reports Access, Registration, and Utilities.

When you start Administrator, Figure 22 appears.
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On the Users tab, you specify which users can gain access to 6120 CCS. The number of licenses you 
purchase dictates the number of users who can use 6120 CCS over the network. You are permitted a 
maximum of five users for each license. You must purchase additional licenses if you need to add more 
than five users.
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NOTE:  You must enter a last name, first name, and user name for each user. Typing information in the 
other fields is optional.

To add a user:
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To edit a user name:
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To delete a user:
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The user is no longer registered in Administrator and can no longer gain access to 6120 CCS. 
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When you start Administrator and click the Permission tab, Figure 23 appears.

On the Permission tab, you specify the viewing and editing permissions of registered 6120 CCS users.

The headings above the Edit and View check boxes vary depending on which entry is selected in the 
Information column. When you select Edit, View is automatically enabled.

In Figure 23 Lenn Lam has been granted permission to view and edit holiday, people, report, and schedule 
information for all departments in 6120 CCS. Lenny can view and edit organization information on the 
Customer Service department only, and can view and edit personal information on himself.
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When you specify the viewing and editing permissions of registered 6120 CCS users, you can grant users 
permission to view and edit particular categories of information across all departments, or selected 
departments, or grant users permission to view particular categories of information on themselves. In 
addition, you can specify which report types a user can view when running reports.
To change a user’s permission attributes for all departments:
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To change a user’s permission attributes for a particular department:

������"���,������	��'��������������
������%���(�����)����������!����0���������������
���������(�����=�"��������0�����������������10����	����8��������
����������(������������� �����������9����������	������:������������!��������
����������(�����(��� ����������0��������	��/�������>����������7�����	���
	����������	����

��
�����
������ ���6������������� ����������0��������	��/�������>�����	������3������������	�������

�����������A������+��	���������1�
����	����!��������
������5���>�!�������!�������������������	������������������A������+���	��������������
����	��

��!��������
������6���,������4����������1�����	���������/8������4������������������+��	�����������1����

�	������

To change a user’s permission attributes for editing and/or viewing personal information or reports:
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To specify which report types a user can view when running reports:
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When you start Administrator and click the Reports Access tab, Figure 24 appears.

You can specify which reports or report categories registered users can view when running reports in 6120 
CCS. You can grant a user access to all reports, to particular categories of reports, or to specific reports. 

There are six categories of reports: PS Reports, General Reports, Management Reports, Budget Reports, 
Schedule Reports, and People Reports. Each category has several types of reports.
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When you start Administrator and click the Registration tab, Figure 25 appears.

On the Registration tab, you can add registration numbers for any additional licenses you purchase. 
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To add a registration number:
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Before you delete a registration number, you must delete the corresponding registered users from the Users 
tab.
To delete a registration number:
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When you start Administrator and click the Utilities tab Figure 26 appears.

On the Utilities tab, you can print user information, change the Administrator password, and compact, 
purge, and optimize the database.
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To change the administrator password:
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To optimize the database:
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To print a list of registered 6120 CCS users:
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