VRManager™
Manual

9/2005 4500-5002-5.0B
WARNING!

Toll fraud is committed when individuals unlawfully gain access to customer telecommunication systems. This is a criminal offense. Currently, we do not know of any telecommunications system that is immune to this type of criminal activity. AltiGen Communications, Inc., will not accept liability for any damages, including long distance charges, which result from unauthorized and/or unlawful use. Although AltiGen Communications, Inc., has designed security features into its products, it is your sole responsibility to use the security features and to establish security practices within your company, including training, security awareness, and call auditing.

NOTICE

While every effort has been made to ensure accuracy, AltiGen Communications, Inc., will not be liable for technical or editorial errors or omissions contained within the documentation. The information contained in this documentation is subject to change without notice.

This documentation may be used only in accordance with the terms of the AltiGen Communications, Inc., License Agreement.

AltiGen Communications, Inc.
4555 Cushing Pkwy.
Fremont, CA 94538
Telephone: 510-252-9712
Fax: 510-252-9738
E-mail: info@altigen.com
Web site: www.altigen.com

TRADEMARKS

AltiGen, AltiServ, AltiWare, AltiContact Manager, AltiReach, AltiLink, AltiConsole, AltiAdmin, ACM Admin, AltiVRPlayer, Zoomerang, Alti-Mobile Extension, SuperQ, IPTalk and VRManager are trademarks or registered trademarks of AltiGen Communications, Inc.

All other brand names mentioned are trademarks or registered trademarks of their respective manufacturers.

Copyright © AltiGen Communications, Inc. 2003. All rights reserved.
9/2005 4500-5002-5.0B
Contents

CHAPTER 1

Introduction ............................................. 1
  About This Guide ...................................... 1
  Requirements ......................................... 1
  VRManager License .................................. 2

CHAPTER 2

Installing VRManager ................................. 3
  Pre-Setup Required for MSDE 2000 ................. 3
  Installing VRManager for a System Administrator 4
    Fresh Install ....................................... 4
    Upgrade from Previous Version .................. 5
  Installing VRManager for a Client ................ 6
  Setting Access Privileges ........................... 6

CHAPTER 3

Using VRManager Admin .............................. 7
  Login .................................................. 7
  VRM Admin Window .................................. 7
    User Page .......................................... 8
    Adding Users ...................................... 8
    Changing the Admin Password ................... 9
  Pooling Page ........................................ 10
  Storage Page ........................................ 11
  Log Page ............................................. 13
  AltWare ACM Page .................................. 15
    Adding Servers .................................... 16
    Changing the Centralized Recording Directory .... 17
CHAPTER 4

Using VRManager Client ................................. 19
  Login .................................................. 19
  VRM Client Main Window ............................. 20
  Menu Bar .............................................. 20
    Quick Access Toolbar .............................. 21
  File Menu ........................................... 22
    Saving Files ...................................... 22
    Export to File .................................... 23
    Change Password .................................. 23
  Edit Menu .......................................... 24
    Searching Voice Records ......................... 24
    Playing Voice Records ........................... 25
    Displaying Columns ............................... 25
    Sorting ........................................... 26
    Media Player Option .............................. 27
  Report Menu ........................................ 27
Introduction

About This Manual

This manual provides instructions for installing and using VRManager. VRManager is designed to facilitate the use of AltiContact Manager’s centralized recording capabilities. This application performs recorded file management — indexing, converting, tracking, playback, reporting, and other critical functions for call center customers who would like to keep recorded files for administrative, legal, or quality assurance purposes.

Requirements

VRManager requires the following:

- VRManager License
- AltiWare AltiContact Manager (5.0 or higher)
- CPU: Pentium IV 2.0 G (minimum)
- Memory: 256 MB
- HD: IDE RAID 0-1 (minimum)
- NIC
- Microsoft Windows 2000/XP/2003
- Java 2 Runtime Environment (SE v1.4.2)
- MDAC (Microsoft Data Access Components)
- Microsoft Internet Explorer 6.0 or later. A minimum installation is sufficient, and Internet Explorer does not have to be the default browser.
VRManager License

VRManager requires a **VRManager License** to be installed at the AltiWare ACM system. You can verify the licenses when you run ACM Admin by selecting **About ACM Admin** on the **Help** menu, then clicking the **License Information** button to view a window that displays licenses and session information.
Installing VRManager

Note: Install VRManager on a different system than the one on which AltiWare ACM Server is installed.

Pre-Setup Required for MSDE 2000

The MSDE 2000 database is installed with the VRManager Setup program. MSDE 2000 requires certain settings in order to install successfully. Before running Setup, please ensure the following.

- File and print sharing must be active on your operating system. To verify:
  1. In Control Panel, double-click Network Connections.
  2. On the Advanced menu, click Advanced Settings.
  3. On the Adaptors and Bindings page, ensure that File and Print Sharing for Microsoft Networks is selected.
- Make sure that Silently succeed is selected in the local security options named below.
  1. In Control Panel, double-click Administrative Tools.
  2. Double-click Local Security Policy.
  3. Expand Local Policies.
  5. Ensure that the following option in the right pane is set to Silently succeed before installing:
• Problems can occur if you use a Terminal Services or Remote Desktop connection to attempt to install a new instance of MSDE 2000. If problems are encountered, restart the VRManager Setup program from the local computer without using Terminal Services or Remote Desktop.

**Installing VRManager for a System Administrator**

To install VRManager for a system administrator, you will use one of two methods: Fresh install and Upgrade from previous version which supports MySQL.

**Fresh Install**

If you do a fresh install, the installation program installs MSDE 2000 and Jservice Loader on your PC automatically.

1. Run the Setup program and follow the installation instructions as they appear on the screen.

![Figure 1. Custom Setup - VRM Admin](image)

2. In the Custom Setup screen, choose to install Voice Record Manager Service and Voice Record Manager Admin, then click Next.

After installation, you can run VRManager Admin from Start > Programs > VRManager > VRM Admin.
Upgrade from Previous Version

If you upgrade from VRManager 5.0A, which uses MySQL, Setup installs VRManager and MSDE 2000 on your PC automatically. Then, in order to access existing data from the new version of VRM Client, you need to execute two more steps to convert the existing MySQL data to the new MSDE 2000 after installation.

To upgrade from a previous version:

1. Stop the VRM service, and run the Setup program.
2. Follow the installation instructions as they appear on the screen.
3. In the Custom Setup screen, choose to install Voice Record Manager Service and Voice Record Manager Admin, then click Next.
4. After installation is complete, download and install ODBC Driver for MySQL. The driver can be found at www.mysql.com.
5. In the DOS Command Prompt window, execute \AltiGen\AGJservices\bin\DBUpdate.exe file.

All your existing data is converted into the new database automatically after execution, and you can use the new version of VRM Client to search data.
Installing VRManager for a Client

To install VRManager for a client system:

1. Run the Setup program and follow the installation instructions as they appear on the screen.

![Custom Setup - VRM Client](image)

2. In the Custom Setup screen, choose to install Voice Record Manager Client or Voice Record Manager Admin.

   If you install VR Admin on a client system, some Browse buttons will not appear.

After installation, you can run VRManager Client from Start > Programs > VRManager > VRM Admin or VRM Client.

Setting Access Privileges

- The directory of centralized records in ACM Server must be shared fully with the VRManager user. This user not only requires privilege to read/write to the shared folder, but also read/write to the local folder.
- The destination of the backup location must be valid and accessible in the local computer or remote computer. The user must have full privilege to read/write to the shared and local folders.
- In Windows 2003 Server, the default setting of the OS security is very robust, so caution should be used when setting users’ access privileges.
Using VRManager Admin

Login

To run VRManager Admin:

1. Choose Start > Programs > VRManager > VRM Admin. The VRM Admin Login dialog box opens.

![VRM Admin Login](image)

2. Enter the VRM Server IP address or server name and Password. (Default password is 22222.)

3. Check the Save Password checkbox if you want VRM Admin to remember the password the next time the program is run.

4. Click OK.

Note: Each Windows user has his own VRM Admin login setting.

VRM Admin Window

VRM Admin has five configuration pages:
- User
- Pooling
- Storage
- Log
- AltiWare ACM
User Page

The VRM User page displays the User List for VRManager clients. Here, an administrator can add or delete users, change user passwords, and change the VRM Admin password.

![User List](image)

*Figure 2. VRM Admin - User page*

Adding Users

To add a new VRManager Client user:

1. Click the New button.
2. In the New User dialog box, enter a User Name, Password and Password Confirmation, then click OK. (The account name is NOT case-sensitive. For example, VRManager does not differentiate between the name “John” and “john” in a user account name.)

![Add New User](image)

*Figure 3. Add New User*

The new user is displayed in the User List field.
Before the user can access VRManager Admin, the system administrator needs to install VRManager Client on the user’s system.

**Changing the Admin Password**

To change the VRM Admin password:

1. Click the **Change Admin Password** button. The Change Admin Password dialog box opens.

   ![Figure 4. Change Admin Password](image)

2. Enter the information in the **Old Password**, **New Password** and **Confirm Password** fields.

3. Click **OK**.
Pooling Page

The pooling page lets you set the location of the primary storage directory. Use the Browse button to select the location. VRM Admin pools the newly recorded files from the AltiWare server, and saves them into the primary storage directory in the .wav format you select here (G.723.1, GSM, or PCM).

![Pooling Page Screenshot]

**Figure 5.** VRM Admin - Pooling Page

**Note:** The Browse button is not available if VRM Admin is running on a different server than VRM Service.
Storage Page

On the Storage page you can set backup conditions for the storage of voice records.

Select one of the following conditions:

- **Automatic delete record without backup** - if selected, VRM Admin will delete records without backing them up. To set additional automatic delete parameters, select any of the following options:
  - Delete records older than x day(s)
  - Delete records when free space below x MB
  - Delete records when free space below x %

- **Schedule Backup** - if selected, VRM Admin will automatically back up, then delete records. To specify backup parameters, select any of the following options:
  - Start when free space below x MB
  - Start when free space below x %

Schedule - for detailed settings, click the Details button. In the Details dialog box, use the drop-down list to select the Schedule Task (Daily/Weekly/Monthly), use the up/down arrows to select the Start Time and to define the Daily Schedule (every x days),

**Figure 6. VRM Admin - Storage Page**

VRManager 11
Weekly Schedule (any day in every x weeks), or Monthly Schedule (any date in every month), then click Apply.

![Details dialog box]

Figure 7. Details dialog box

Use the Advanced button to set a Start Date and End Date; or check the Repeat Task checkbox to set up parameters for a continuous schedule, then click OK.

![Advanced dialog box]

Figure 8. Advanced dialog box.

Check the Show multiple schedules checkbox to display and set up more than one schedule. You can add new multiple schedules, then modify them.
• **Backup Storage** - enter the location for the backup storage, or use the **Update** button to select a new location. If you click the **Update** button, the following dialog box opens:

![Backup Storage Dialog Box]

This can be a local path or network path. The destination of the backup location must be valid and accessible in the local computer or remote computer. The user must have full privilege to read/write to the shared and local folders. Also, VRManager supports backup to DVD/RW; simply enter the path for the DVD/RW location.

**Note:** The **Browse** button is not available if VRM Admin is running on a different server than VRM Service.

• **Execute Now button** - clicking this button will begin backup of records.

When you have finished setting backup parameters, click **Apply** or **OK**.

### Log Page

A log file for the VRM server is created each day named “yyyymmdd.log” (for example, 20040404.log). A daily report for the VRM server is also created “yyymmdd.rpt” (for example, 20040404.rpt). The Log window allows an administrator to set the directory paths for VRM log and report.
Note: The **Browse** buttons are not available if VRM Admin is running on a different server than VRM Service.

![Figure 9. VRM Admin - Log page](image)

- **Set Log Directory** - use the **Browse** button or enter a path in the field to specify where you want log files to be saved; check the **Delete the log files older than x days** checkbox to delete archived log files.

- **Set Daily Report Directory** - use the **Browse** button or enter a path in the field to specify where you want daily report files to be saved; check the **Delete the log files older than x days** checkbox to delete archived daily report files.

- **Send daily report by mail** - if you check this option, VRM will send a report **When there is a warning or error** or **Always**. Use the **Mail Configuration** button to configure the recipient’s email address. Use the **Test** button to send a test email.

Click **Apply** or **OK** when finished.
AltiWare ACM Page

The AltiWare ACM page displays the AltiContact Manager servers and centralized recording directories that VRManager will access. Here, administrators can add or delete ACM servers, and specify the centralized recording directory for the specified ACM server.

Figure 10. VRM Admin - AltiWare ACM page
Adding Servers

To add a new ACM server, do the following:

**At the AltiServ system**

1. Make sure the Centralized Storage directory is located on the local drive on the AltiServ system.
2. Share the storage directory with Full Control to a domain user or local administrator.

**At the VRM Server**

1. In the AltiWare ACM page of VRM Admin, click the **New** button. The Add New Server dialog box appears.

![Add New Server](image)

2. Enter the **ACM Server IP Address**, **Centralized Recording Directory** (the Share name of the centralized recording folder), **User Name** and **Password**. Then click **OK**. If the user account belongs to an NT domain, you must enter “NTDOMAIN;username” in the User Name edit box. If the account is local Administrator, just enter administrator.

After adding a new server, VRM Service immediately checks the AltiWare server for the **VRManager License**.

The newly added server is displayed in the **AltiWare ACM Server List** field.

**Note:** VRManager starts converting all voice recording data as soon as the ACM Server information is added to the AltiWare ACM Server List.
Changing the Centralized Recording Directory

To edit an ACM server’s location for the centralized recording directory, highlight the ACM server in the server list, then input the new location in the Centralized Recording Directory field.
Using VRManager Client

Login

To run VRManager Client:

1. Choose Start > Programs > VRManager > VRM Client. A Login dialog box opens.

2. Enter the VRM Server IP address or server name, User name and Password.

3. Check the Save Password checkbox to have VRM Client remember the password the next time the program is run.

4. Click OK.

Note: Each Windows user has his own VRM Client login setting.
VRM Client Main Window

When you start VRM Client, the first window you see is the VRM Client main window.

![VRM Client main window](image)

Figure 2.  VRM Client main window

At the top is a menu bar, and below is a quick-access toolbar. At the bottom is a scroll bar for viewing the display columns.

**Note:** Each Windows user has his own VRM Client display column in the main window.

**Menu Bar**

Using the menus, you can perform the following functions:

- **File** – Save As, Export to File, Change Password, Exit
- **Edit** – Search, Play, Display Column, Option
- **Report** – Generate report
- **Help** – VRM Client version information
Quick Access Toolbar

![Buttons](image)

*Figure 3. Quick Access Toolbar*

The toolbar contains buttons that are menu shortcuts:

- **Save As.** Saves the selected voice recording to a specified location.
- **Search.** Opens the Search dialog box.
- **Play.** Plays the selected voice recording.
- **About.** Opens VRM Client version information.
File Menu

Saving Files

To save a file, click on a voice record in the main window to highlight it, and click the **Save As** button. OR, right-click on a voice record, and select **Save As**. OR, click on a voice record to highlight it, and choose **File > Save As** from the main menu.

![Figure 4. Saving a Voice Record](image)

22  VRManager
Export to File

To export search results to a tab-separated text file (.txt), choose **File > Export To File** from the main menu, OR right-click the search results list and choose **Export To File**.

![Figure 5. Export to File](image)

Change Password

To change your password:

1. Choose **File > Change Password** from the main menu.
2. In the **Change User Password** dialog box, enter the necessary information in the **Old Password**, **New Password** and **Confirm Password** fields, then click **OK**.

![Figure 6. Change User Password](image)

The new password applies at the next log in.
Edit Menu

Searching Voice Records

To search voice records, choose Edit > Search or click the Search button in the toolbar. In the Search dialog box, you can search based on the following conditions:

![Search dialog box]

The relational symbols for each condition include:

- `=` (equal)
- `<` (greater than)
- `>` (less than)
- `>=` (less than or equal to)
- `<=` (greater than or equal to)
- `<>` (not equal)
- `like` (look for sub-string)
- `btwn` (between)
- `in`—searches the results in sets; for example, CallerID “In” “101 AND 102” means CallerID equals 101 or CallerID equals 102.

Notes

- Typing “OR” in upper case in the edit box means “or.”
- Typing “AND” in upper case in the edit box means “and.”
• To leave out a condition, leave the edit box empty.
• The date/time format is the same as the system format of the operating system.
• Only the Comment column will be editable directly from the main view window.

Playing Voice Records

To play a voice record:

Click on a voice record in the main window to highlight it, and click the Play button. OR, right click on a voice record and select Play. OR, click on a voice record to highlight it, and choose Edit > Play from the main menu.

Figure 8. Playing Voice Records

Note: Deleted voice files are not played.

Displaying Columns

You can select which columns you want displayed in the main view window. These are the column headers you can select from:

• ID
• Callee ID
• Session ID
• Caller ID
• DNIS
• Workgroup
• Length
• Date
• **State**—there are three states that a record file can be in:
  — *Delete* - if in this state, a record cannot be played or saved.
  — *Backup* - if in this state, you must manually put the right backup media in the path if you back up the record and remove it.
  — *Normal* - if in this state, the file can be played or saved.
• **Comment**

To select columns for display:

1. Choose **Edit > Select Column**.
   The Select Column dialog box opens. The fields in the **Visible** list are displayed as columns under the VRM toolbar..

2. Use the arrow keys (< or >) to move a field from one list to the other. You can use the << or >> buttons to move the entire group of fields from one list to the other.
3. Click **OK** when finished.

**Sorting**

In the main view window, you can click on a specific column heading to sort records in ascending or descending order on that field. You can use the scroll bar at the bottom of the window to view all the displayed columns.
Media Player Option

VRM client plays the selected file using a media player defined by the user. If the media player is not defined, VRManager does not play the file, and instead opens the Media Player Location dialog box so you can assign a media player. You can also select the media player by going to Edit > Option. In the Option dialog box, select the Media Player Location by typing the path in the field or using the browse button (...), then click OK.

Figure 10. Option dialog box

Report Menu

You can generate reports based on agent, workgroup, DNIS or date.

To generate a report:


Figure 11. Report Generation dialog box

2. In the Report Generation dialog box, click the Down arrow to select From and To dates from a calendar.

3. Select one of the following format options:
- **Group by Agent Extension** - enter the extension in the Call ID field.
- **Group by Workgroup** - enter the workgroup number in the Workgroup field.
- **Group by DNIS** - enter the DNIS number in the DNIS field.
- **Group by Day (Daily Summary)** - formats report based on date period summary for each day.

4. Click **OK**.

5. VRM Client generates a separate **Report** window displaying the selected report parameters. From there, you can select **Print Setup**, **Preview**, **Print**, or **Export** (as a tab-separated text file).

![Report Results](image)

*Figure 12. Report Results*
Index

A
adding
  client users 8
  servers 16
admin password, changing 9
AltiGen Communications
  contact information ii
AltiWare ACM page 15
automatic delete record without backup 11

B
backup 6, 13
  location 6, 13
  schedule 11
  storage 13

C
centralized recording directory,
  changing 17
changing
  admin password 9
  centralized recording directory 17
  client password 23
client users, adding 8
  column display 25

D
deleting records 11
  displaying columns 25

E
Execute Now button 13
  export to file 23

I
installing VRManager 3

L
license, VRManager 2
log file, configuring 13
login, VRM Client 19

M
media player, assigning 27

P
password
  changing admin 9
  changing client 23
playing voice records 25
privileges 6

R
records
  playing 25
  searching 24
  sorting 26
reports, generating 27
requirements, VRManager 1

S
saving files 22
schedule backup 11
search symbols 24
searching voice records 24
servers, adding 16
sorting records 26
storage
  backup 13
  directory, setting 10

T
toolbar 21

V
voice records
  playing 25
  searching 24
VRM Admin
## Index

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>AltWare ACM page</td>
<td>15</td>
</tr>
<tr>
<td>log page</td>
<td>13</td>
</tr>
<tr>
<td>pooling page</td>
<td>10</td>
</tr>
<tr>
<td>storage page</td>
<td>11</td>
</tr>
<tr>
<td>user page</td>
<td>8</td>
</tr>
<tr>
<td>VRM Client</td>
<td></td>
</tr>
<tr>
<td>edit menu</td>
<td>24</td>
</tr>
<tr>
<td>file menu</td>
<td>22</td>
</tr>
<tr>
<td>generating reports</td>
<td>27</td>
</tr>
<tr>
<td>login</td>
<td>19</td>
</tr>
<tr>
<td>VRManager</td>
<td></td>
</tr>
<tr>
<td>configuring</td>
<td>7</td>
</tr>
<tr>
<td>installing</td>
<td>3</td>
</tr>
<tr>
<td>license</td>
<td>2</td>
</tr>
<tr>
<td>requirements</td>
<td>1</td>
</tr>
<tr>
<td>VRManager Admin</td>
<td></td>
</tr>
<tr>
<td>using</td>
<td>7</td>
</tr>
<tr>
<td>VRManager Client</td>
<td></td>
</tr>
<tr>
<td>using</td>
<td>19</td>
</tr>
</tbody>
</table>