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Getting Started With Apple Media Tool provides the information you need to
install and begin to use Apple Media Tool. Apple Media Tool is an authoring
environment that enables you to create interactive multimedia titles, such as
corporate presentations and kiosks, which combine QuickTime movies,
pictures, sound, and text. With Apple Media Tool, which runs on Mac
OS–based computers, multimedia designers can quickly and easily produce
professional-quality titles that can be played on both Mac OS and Microsoft
Windows computers. 

No programming is required to use Apple Media Tool. Programmers can use
a complementary product, Apple Media Tool Programming Environment, to
enhance designs that are implemented within Apple Media Tool and to extend
the capabilities of Apple Media Tool itself.

Who should read this guide

This guide is intended for designers, members of production teams,
newcomers to multimedia, and experienced multimedia professionals who
wish to create multimedia titles. Examples of Apple Media Tool users include
commercial multimedia designers, educational users, and corporate users
producing marketing communications.

Programmers may wish to investigate Apple Media Tool Programming
Environment in addition to Apple Media Tool. 
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What’s covered in this guide

You’ll find the following content in this guide:

m Chapter 1, “Introduction to Apple Media Tool,” provides an overview of
Apple Media Tool, including its benefits, fundamental concepts, and user
interface elements. This chapter also gives an overview of the multimedia
authoring process and the role of Apple Media Tool in this process.

m Chapter 2, “Installing Apple Media Tool,” provides detailed hardware and
software requirements and instructions for installing Apple Media Tool.

m Chapter 3, “Building a Sample Project,” provides step-by-step instructions
for building a sample project and converting it into a title that you can play.
This chapter also covers the basic concepts and fundamental skills you
need to use the software effectively. Once you have completed this chapter,
you will be ready to start creating multimedia titles.

What’s not covered in this guide

This guide does not include the following:

m Media creation

Apple Media Tool is designed for combining existing media, not for
creating the media themselves.

m Programming with Apple Media Tool Programming Environment
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For more information

You can obtain more information from the following resources:

m Apple Media Tool Reference Guide

This guide provides more detailed information on Apple Media Tool.

m Apple Media Tool Addendum

This document, which is provided on the Apple Media Tool CD-ROM,
includes information about new features of Apple Media Tool version 2.0.

m Apple Multimedia Program

This program provides multimedia marketing, technical, and business
resources to its members. For information on the Apple Multimedia
Program, contact Apple Developer Support at 408-974-4897 or go to
http://www.amp.apple.com/ on the World Wide Web.

m APDA

You can obtain Apple Media Tool Programming Environment from APDA.
APDA is Apple Computer’s worldwide source for development tools,
technical resources, training products, and information for anyone
interested in developing applications on Apple platforms. Contact APDA at
800-282-2732 (United States), 800-637-0029 (Canada), 716-871-6555
(international), or APDA@eworld.com on the Internet.

m Further reading

There are many books that will provide you with information on
multimedia authoring. Recommendations include the following:

m Multimedia Demystified:  A Guide to the World of Multimedia from Apple
Computer, Inc. (Random House Electronic Publishing, 1994)

m QuickTime:  The Official Guide for Macintosh Users, Judith L. Stern and
Robert A. Lettieri (Hayden, 1994)
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This chapter provides an overview of Apple Media Tool and its role in the
multimedia authoring process.

About Apple Media Tool

Apple Media Tool is an authoring environment that enables you to create
multimedia titles incorporating QuickTime movies, pictures, sound, and text.
With its powerful and easy-to-use graphical user interface, Apple Media Tool
lets multimedia designers quickly produce professional-quality titles that can
be played on both the Mac OS and Microsoft Windows platforms.

With Apple Media Tool, you can do the following:

m Specify the screens that will appear when you play your title and the ways
in which the user can navigate them.

m Specify the layout of each screen and the media each will present.

m Define the interactive behavior of each screen.

m Preview your title as you implement it.

m Create a stand-alone title when your implementation is complete.

Apple Media Tool Programming Environment, a complementary product for
programmers, can be used to enhance designs that are implemented within
Apple Media Tool and to extend the capabilities of Apple Media Tool itself.
Together, these two products provide a complete, high-performance,
professional solution intended to meet the needs of both individual
multimedia designers and multimedia production workgroups.
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Benefits of Apple Media Tool

Apple Media Tool offers several important benefits.

Anyone can be a multimedia designer

With Apple Media Tool, anyone can be a multimedia designer. You don’t have
to be a programmer or assemble a team of experts before you can produce
professional-quality titles.

An easy-to-learn and easy-to-use graphical user interface 

With its menus, windows, tool palettes, dialog boxes, and direct-manipulation
operations, Apple Media Tool takes advantage of the same easy-to-use and
easy-to-learn graphical user interface that you enjoy in the Mac OS. As a
result, you’re working productively right away and you have more time to
concentrate on creating compelling media content and a superior title.

A powerful multimedia authoring environment

Apple Media Tool provides a powerful direct-manipulation environment and a
rich set of tools and menu commands that enable you to rapidly incorporate
media and interactivity into your title. Apple Media Tool even lets you
preview your title at any stage prior to its completion.

Also included with Apple Media Tool are the following two applications that
make the environment even more powerful:

m Runtime Maker, a simple compiler that translates your design into a stand-
alone title that plays on either the Mac OS or Microsoft Windows platform.

m Apple Media Tool Converter, a utility that you can use to

m Convert a media file into a cross-platform compatible format (for
example, WAVE instead of AIFF)

m Identify cross-platform incompatibilities related to media filenames and
file formats

m Upgrade your work from previous versions of Apple Media Tool to the
current version
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Workgroup support

Apple Media Tool and its complementary product, Apple Media Tool
Programming Environment, are intended to meet the needs of multimedia
production workgroups by enabling different members of the team to work
on different aspects of a project, often at the same time. Programmers can use
Apple Media Tool Programming Environment to enhance designs that are
implemented by human interface designers, graphic artists, and other
multimedia experts using Apple Media Tool. Because media are stored
separately from the title that uses them, media experts can use their favorite
media creation tools to create and upgrade media throughout the authoring
process. 

AppleScript support

You can achieve greater efficiency and productivity by using AppleScript to
automate most of the common operations in Apple Media Tool, for example,
creating screens and replacing media.

Components of Apple Media Tool projects

Titles created using Apple Media Tool are composed of the following
components:

m Media

m Projects

m Screens

m Maps

m Objects

m Events

m Actions
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Media

Media are the visual and auditory materials that convey the information you
wish to present in your title. Examples of media are QuickTime and
QuickTime VR movies, pictures, sounds, and Rich Text Format (RTF) text.
You store the media that are used by your title on your hard disk drive, CD-
ROM disc, or network. As it plays, your title reads this media information.

Apple Media Tool is intended for integrating existing media into a title, not
for creating the media themselves. You can create media with tools such as
graphics applications and text editors. You can run these tools from Apple
Media Tool when you need to modify particular media items you are using.

Projects

The project is the fundamental component of Apple Media Tool. A project is
what you design and implement within Apple Media Tool. You compile your
project to create the stand-alone title. 

Screens

Screens are the fundamental components of a project. You use Apple Media
Tool to create the screens that will appear, one at a time, as the title plays.
Creating a screen involves arranging the media the screen will present and
defining the areas of the screen with which the user will be able to interact
when the title plays.

Maps

A map provides a visual overview or storyboard of your project. You use a
map to create the screens that compose your project and to define the ways in
which the user can navigate the screens when the title plays.
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Objects

Objects are the fundamental components of screens. In Apple Media Tool,
you incorporate media into your project by creating objects that use media on
the screens. You add interactivity to your title by making objects respond to
user operations such as typing and mouse activity. The objects contained by a
screen can produce sound, appear on the screen, or become sensitive to user
activity as the title plays. 

Once you create an object, you can set parameters that control characteristics
such as its size, location on the screen, and sensitivity to user activity. In
addition, you can assign a duration to most types of objects so that you
control the timing of an object’s interactivity as the title plays. 

An object is not required to use media. An object that uses no media is said to
be empty. Creating objects that are empty can be useful when some area of a
screen needs to be interactive but requires no additional visual or auditory
component from media. When a title plays, it does not need to read media
information for an object that is empty. Consequently, you can optimize the
performance of your title by using empty objects whenever possible.

An object that uses a media item does not physically contain the media item.
Instead, the object contains a reference to the location where the media item
resides.

Events

Events are messages sent to objects as a title plays. Events result from user
activity or from changes in the state of the title. Examples of user activity
include typing, clicking the mouse button, and moving the pointer. Examples
of changes in the state of the title include the appearance of a screen or the
expiration of the duration for an object. In Apple Media Tool, you specify the
behavior of an object by defining the events to which the object responds. 
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Actions

An action is what an object does in response to an event. You can specify one
or more actions to perform for each event to which an object responds. An
object can respond to a particular event by performing an action itself or by
making another object perform an action.

You can specify three types of actions within Apple Media Tool. The first
type of action is a command. Commands control various aspects of screens
and objects, such as their visibility or responsiveness to user activity while the
title plays.

The second type of action is a link. Links are used to go from one screen to
the next as the title plays.

The third type of action is an effect. Effects control the visual effect that
applies to objects as they appear or disappear on the screen.

Fundamental elements of the Apple Media Tool user interface

Apple Media Tool provides a set of graphical user interface elements with
which you can manipulate the components of your project. In addition to its
menus and dialog boxes, Apple Media Tool provides the following
fundamental elements:

m Tool palette

m Map window

m Display window

m Browser miniwindow

m Media miniwindow

m Info miniwindow

m Scroller miniwindow

You can perform many operations by dragging icons between miniwindows,
windows, and the desktop. 
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Tool palette

The Tool palette provides tools for performing the following operations
within the Map or Display windows:

m Selecting and positioning screens and objects

m Resizing objects

m Creating screens and objects

m Defining the ways in which the user can navigate screens when the title
plays

m Defining the areas of objects that are sensitive to mouse activity

m Controlling which Apple Media Tool user interface elements are visible as
you use Apple Media Tool

Map window

The Map window presents the project map.
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Display window

The Display window provides a view of the currently selected screen. You use
the Display window to lay out the objects on a screen.

Browser miniwindow

The Browser miniwindow presents four panes that list the screens, objects,
events, and actions that your project contains. The Browser miniwindow is
designed to reflect the containment relationships of these components.
Consequently, clicking an item in one pane causes the adjacent pane on its
right to present a list of the components the item contains. For example,
clicking a screen causes the adjacent pane to list the objects the screen
contains.
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Media miniwindow

The Media miniwindow presents the media items that your project may use.
You are responsible for specifying which media appear in the Media
miniwindow.

Info miniwindow

The Info miniwindow shows the coordinates of the pointer as you move it
within the Display window. In addition, it shows the current coordinates and
size of a selected object as you position or resize the object within the Display
window.
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Scroller miniwindow

The Scroller miniwindow presents a small view of the map which, when you
scroll it, causes the contents of the Map window to scroll accordingly. The
Scroller miniwindow is useful when the map is so large that you cannot see
all of it at once within the Map window.

Apple Media Tool Programming Environment

With Apple Media Tool Programming Environment, programmers can
enhance projects created with Apple Media Tool and extend the capabilities
of Apple Media Tool itself. Programmers working in Apple Media Tool
Programming Environment use Apple Media Language, a powerful object-
oriented programming language that runs on both the Mac OS and Microsoft
Windows platforms. Apple Media Language gives programmers access to the
platform-specific functionality available in the toolbox of either platform.

Project enhancement

Programmers can use Apple Media Tool Programming Environment for
project enhancements such as

m Integration of external C language routines

m Integration of database functionality

m Platform-specific performance optimizations

m Implementation of interactivity that is difficult or impossible to express
using Apple Media Tool
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You can use Apple Media Tool to save a project as an Apple Media Language
description file. Programmers use this Apple Media Language version of the
project to implement the enhancements. The resulting Apple Media Language
program is compiled into the stand-alone title. 

Extension of Apple Media Tool

The AMT Standard Engine defines the types of media, objects, events, and
actions you can use within Apple Media Tool. Programmers can customize
the engine to extend the functionality of Apple Media Tool. Because Apple
Media Tool uses the engine that resides within the same folder as it does, you
can replace the AMT Standard Engine with a custom engine and the Apple
Media Tool user interface will reflect the extensions defined by the custom
engine.

The multimedia authoring process

This section provides an overview of the process a production team
undertakes to author a multimedia title. 

The production team may consist of a single person or a multifunctional
group that includes the following team members:

m Multimedia producers such as human interface designers and educators

m Media creation experts such as graphic artists, illustrators, animators,
writers, and composers

m Programmers and scripting experts
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The following table presents a typical distribution of responsibilities among
the functional groups:

Multimedia producers Media creators Programmers

Plan the product X X X

Assemble the media X

Create the project X

Enhance the project X

Compile the project X X

Test the title X X

Distribute the title X

Plan the product

The content of the product plan and the method used to create it may vary
from team to team, but it should include the following:

m Detailed product specification

m Definition of screens and their relationships

m Definition of required media

m Definition of any required programming

m Budget and schedule

Assemble the media

You can acquire existing media for your title, or you can create original media
using a separate media creation tool. You must store media in a file format
that Apple Media Tool can recognize.

Because a title and the media it uses are stored in separate locations, you can
create new versions of your media at any time. Your title will refer to the new
versions automatically. As a result, you can refine the media throughout the
multimedia authoring process.
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Before you decide what media to use, consider the platform on which you
intend to deploy your title. Platform performance and available memory limit
the number and size of the media each screen can use. In addition, Microsoft
Windows is more restrictive than Mac OS with regard to filenames, media file
formats, and sound playback. For more information, see “Requirements for
Windows Titles” in Appendix B of Apple Media Tool Reference.

Create the project

You use Apple Media Tool to create the project that forms the basis for the
title. The following tasks summarize this process:

m Define the project map

m Lay out the objects on the screens

m Define the interactions of the objects

m Play a preview of the title within Apple Media Tool

m Conduct user testing

m Save your project as an Apple Media Language description file

Enhance the project

Programmers can use Apple Media Tool Programming Environment to
enhance the Apple Media Language version of the project created with Apple
Media Tool.

Compile the project into a title

If you complete your project using Apple Media Tool alone, you can use
Runtime Maker to compile the Apple Media Language version of your project
into a stand-alone title. If, instead, you enhance your project using Apple
Media Tool Programming Environment, you must use the compiler provided
with that product to create the stand-alone title.
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Test the title

Play your stand-alone title to test its functionality. If you are creating it for
multiple platforms, test it on each platform. 

Distribute the title

There are several different ways you can distribute your title and the media it
uses:

m CD-ROM disc

m Hard disk

m Corporate network
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This chapter explains how to install Apple Media Tool and describes the
hardware and software you need in order to use Apple Media Tool and play
the multimedia titles you create with Apple Media Tool.

Hardware requirements

This section describes the hardware you need in order to use Apple Media
Tool and play the multimedia titles you create with Apple Media Tool.

Hardware requirements for using Apple Media Tool
m A Mac OS–based computer with a Motorola 68020, 68030, 68040, or

PowerPC 601, 603, 604 processor

m A minimum of 8 megabytes (MB) of RAM, 5 MB of which is available 

The recommended amount of RAM is 12 MB or more. You may need more
than 8 MB of RAM if your project is large or if you are running version 7.5
or later of Mac OS system software.

m A hard disk with a minimum of 10 MB of hard disk space available 

If you intend to store media on the hard disk, the hard disk must have
sufficient additional space available to accommodate the media.

m A CD-ROM drive
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Hardware requirements for playing Mac OS–based titles
m A Mac OS–based computer with a Motorola 68020, 68030, 68040, or

PowerPC 601, 603, or 604 processor

m A minimum of 2 MB of available RAM

You need this amount of RAM to play the smallest possible title. The
recommended amount of RAM is 8 MB or more.

m A CD-ROM drive if media are stored on a CD-ROM disc

Hardware requirements for playing Microsoft Windows–based titles
m A Microsoft Windows–based computer with an Intel 80386, 486, 486SX,

486DX, or Pentium processor

m A minimum of 4 MB of RAM

You need this amount of RAM to play the smallest possible title. The
recommended amount of RAM is 8 MB or more.

m A CD-ROM drive if media are stored on a CD-ROM disc

m A sound card

Software requirements

This section describes the software you need in order to use Apple Media
Tool and play the multimedia titles you create with Apple Media Tool.

Software requirements for using Apple Media Tool

You need version 7.1 or later of Mac OS system software. Other software you
need is provided during installation of Apple Media Tool.
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Software requirements for playing Mac OS–based titles

Once you are using Apple Media Tool, you have the software you need to play
your Mac OS–based title on your computer. However, if you are playing your
title on a Mac OS–based computer that doesn’t have Apple Media Tool
installed, that computer must have the following software:

m Version 7.1 or later of Mac OS system software

m QuickTime 2.1

m Sound Manager 3.1

Software requirements for playing Microsoft Windows–based titles
m Version 3.1 or 3.11 of Microsoft Windows system software or Windows 95

system software.

m A video driver capable of displaying 256 or more colors on your monitor

m QuickTime 2.03 for Microsoft Windows

What’s included with Apple Media Tool

The Apple Media Tool package includes a CD-ROM disc titled Apple Media
Tool 2.0. This disc includes an Installer application program that installs the
following software:

Apple Media Tool software
m Apple Media Tool

This is an application program for creating titles that play on the Mac OS
and Microsoft Windows platforms.

m Apple Media Tool Converter

This is an application program that provides a set of conversion utilities
related to media file formats, cross-platform compatibility, and older
versions of projects.

m Runtime Maker

This is an application program that compiles Apple Media Tool projects
into titles that play on the Mac OS and Microsoft Windows platforms.
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m AMT Standard Engine, AMT Minimal Engine, and AMT Engine
Resources

These support Apple Media Tool. The standard engine includes support for
QuickTime VR. When your project does not require QuickTime VR, using
the minimal engine instead of the standard engine reduces the size of the
resulting title by roughly 0.5 MB.

m Two Codes folders and the files contained within each one

These support Runtime Maker. One Codes folder corresponds to the AMT
Standard Engine and the other to the AMT Minimal Engine. When
Runtime Maker compiles your project into a title, it uses the Codes folder
that resides in the same folder as it does. The Codes folder in that location
must correspond to the engine that Apple Media Tool used when you
created your project.

System software

The Installer makes sure that your system software provides the following
functionality. Which files the Installer places in your System Folder depends
on the processor your computer uses and the version of Mac OS system
software you are running.

m AppleScript

Provides system support for automation of routine or complex tasks

m QuickTime 2.1

Provides system support for sound, video, graphics, and animation

m Sound Manager 3.1

Provides system support for digital audio

m Macintosh Drag and Drop

Provides system support for drag-and-drop operations

m Code Fragment Manager (CFM)

Enables Apple Media Tool to run on Mac OS–based computers using a
Motorola 68020, 68030, or 68040 processor

m StdCLibInit

Enables Apple Media Tool to run on Mac OS–based computers using a
Power PC 601, 603, or 604 processor

18 Chapter  2



Installing Apple Media Tool software

This section provides instructions for installing the software.

Installing all appropriate Apple Media Tool software

To install the software, follow these steps:

1 Insert the Apple Media Tool 2.0 disc into your CD-ROM drive.

The Apple Media Tool 2.0 disc icon appears on the desktop.

2 Double-click the Apple Media Tool 2.0 disc icon.

A window opens, presenting the items on the disc.

3 Double-click the Installer application program icon.

A dialog box appears.

4 Click Continue.

The old dialog box disappears and a new one appears.

In the Destination Disk box, you should see the name of the hard disk on
which you want to install Apple Media Tool software. If you don’t, click the
Switch Disk button until the name of the correct disk appears.

By default, Easy Install is chosen in the pop-up menu at the upper left of the
dialog box. With Easy Install chosen, clicking the Install button will install all
of the Apple Media Tool software and all of the system software required by
your computer.
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5 Click Install.

If you have other applications open, you will see a message that these
applications cannot be running during installation. Click Continue.

The Installer application program quits any other running applications and
begins to install the software. Progress information appears as the installation
proceeds. If you want to cancel the installation, click Cancel. 

When the software is installed, you see a message that installation was
successful, and you are prompted to restart your computer.

6 Click Restart.

Your computer restarts. You can begin using Apple Media Tool.

Custom installing Apple Media Tool, AppleScript, or QuickTime
software

A custom installation of Apple Media Tool installs all of the Apple Media
Tool and system software listed earlier in the chapter with the exception of
AppleScript and QuickTime. You can custom install the AppleScript or
QuickTime software separately.

To perform a custom installation, follow these steps:

1 Insert the Apple Media Tool 2.0 disc into your CD-ROM drive.

The Apple Media Tool 2.0 disc icon appears on the desktop.

2 Double-click the Apple Media Tool 2.0 disc icon.

A window opens, presenting the items on the disc.

3 Double-click the Installer application program icon.

A dialog box appears.
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4 Click Continue.

The old dialog box disappears and a new one appears.

In the Destination Disk box, you should see the name of the hard disk on
which you want to install the software. If you don’t, click the Switch Disk
button until the name of the correct disk appears.

5 From the pop-up menu at the upper left of the dialog box, choose Custom Install.

A list of the software you can install appears.

6 Click any of the Apple Media Tool, AppleScript, or QuickTime checkboxes to select them.
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7 Click Install.

If you have other applications open, you will see a message that these
applications cannot be running during installation. Click Continue.

The Installer application program quits any other running applications and
begins to install the software. Progress information appears as the installation
proceeds. If you want to cancel the installation, click Cancel. 

When the software is installed, you see a message that installation was
successful, and you are prompted to restart your computer.

8 Click Restart.

Your computer restarts. 

Custom Remove works in basically the same way as Custom Install. 

Swapping the minimal engine and the standard engine

Apple Media Tool uses the AMT Standard Engine by default. If your project
will not require QuickTime VR, Apple Media Tool should use the AMT
Minimal Engine instead so that your title will be smaller.

Apple Media Tool uses the engine that resides in the same folder as it does, so
you will need to move the AMT Standard Engine out and move the AMT
Minimal Engine into that folder if you want Apple Media Tool to use the
minimal engine. Follow these steps:

1 If you have not already done so, install Apple Media Tool following the instructions
presented earlier in this chapter.

2 Quit Apple Media Tool if it is open.

3 Double-click the Apple Media Tool 2.0 folder icon.

In the window that opens, you see a second Apple Media Tool folder and a
Runtime Maker folder.

4 Double-click the second Apple Media Tool folder icon.

The window that opens contains the Apple Media Tool application program
and the AMT Standard Engine. You also see folders for the AMT Minimal
Engine and the AMT Standard Engine.
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5 Drag the AMT Standard Engine icon to the AMT Standard Engine Folder.

The standard engine is put into the folder.

6 Double-click the AMT Minimal Engine Folder icon.

The window that opens contains the AMT Minimal Engine.

7 Drag the AMT Minimal Engine icon to the Apple Media Tool folder that contains the Apple
Media Tool application program.

The minimal engine is now in the same folder and at the same level as the
Apple Media Tool application program.

The installation process places the Codes folder corresponding to the AMT
Standard Engine inside the same folder as the Runtime Maker application
program. When you swap engines, you must swap Codes folders as well.

1 Double-click the Runtime Maker folder icon.

In the window that opens, you see the Runtime Maker application program
and the Codes folder that corresponds to the standard engine.

2 Drag the Codes folder icon to the Standard Codes Folder.

The Codes folder corresponding to the standard engine is put into the folder.

3 Double-click the Minimal Codes Folder icon.

The window that opens contains the Codes folder that corresponds to the
AMT Minimal Engine. 

4 Drag the icon for this Codes folder to the Runtime Maker folder.

The Codes folder corresponding to the minimal engine is now in the same
folder and at the same level as the Runtime Maker application program.
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This chapter shows you how to build a sample project and compile it into a
multimedia title that you can play. By the end of this chapter, you should have
a good understanding of the basic concepts and fundamental skills needed to
use Apple Media Tool.

This chapter introduces the following concepts:

m Starting a new project and designing a map

m Adding media to a project

m Adding objects to a screen

m Adding interactivity to objects within a screen

m Previewing a title before compiling it

m Compiling a project using Runtime Maker
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About the sample project

In this chapter you will build your own version of the Journey to India sample
project provided on the Apple Media Tool 2.0 disc in the Apple Media Tool
package. After you finish building the project, you will use Runtime Maker to
compile your project into both a Mac OS–based and Microsoft
Windows–based version of your title. When you play your title, you will see
that it is composed of a collection of screens that appear one at a time. 

The first screen that will appear is an introductory screen that will show a
photograph of the Taj Mahal while music plays in the background. Several
seconds later, the main screen will appear. It will show three photographs
that you can click to view other screens. Clicking the upper-left photograph
will cause a screen that contains information on Rajasthan to appear. Clicking
the bottom-left photograph will cause a screen that contains information on
Varanasi to appear. Clicking the bottom-right photograph will cause a screen
that contains information on Darjeeling to appear. Clicking the lower-left
button of the Rajasthan, Varanasi, or Darjeeling screens will bring back the
main screen.
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Starting a new project and designing a map

The first step in building this sample project is to design its map, which is
like a visual outline or storyboard for the project. To design a new map, you
open a new project, create the screens that constitute the project, and connect
the screens to define the ways in which the user can navigate them when the
title is playing.

Opening a new project

To open a new project:

m Double-click the Apple Media Tool application icon on the desktop.

Apple Media Tool opens and an untitled Map window and several
miniwindows appear in the Map window. You create and connect screens in
the Map window.

Creating screens

To create the five screens that constitute this project, follow these steps:

1 Double-click the Creation tool in the Tool palette.

The pointer takes the shape of the Creation tool symbol.

Note:  When you click a tool in the Tool palette once, the pointer returns to
the Selection tool after you use the tool for the first time. When you double-
click a tool in the Tool palette, the pointer retains that tool until you select a
different tool. The background of the tool in the Tool palette turns light gray
after you click the tool once and black after you double-click the tool.

Shortcut:  Another way to change the pointer to the Creation tool is to hold
down the x (Command) key while the pointer is over the Map window.
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2 Create five screens by clicking five different locations inside the Map window.

Every time you click, a new screen appears. The newly created screens snap
to an invisible grid. Each new screen receives a name. The first screen is
named Screen 1, the second screen is named Screen 2, and so on.

3 Click the Selection tool in the Tool palette.

The pointer takes the shape of the Selection tool symbol.

4 Drag the screens in the Map window to reposition them as shown.
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Naming screens

To give the screens more descriptive names, follow these steps:

1 Click the Selection tool in the Tool palette.

2 Click the name box of Screen 1.

A rectangular box appears around the name, and the name is highlighted.

3 Type Intro.

4 Press Enter.

The rectangular box disappears.

5 Change the names of the other screens as shown.
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Labeling screens

A title begins playing at the root screen. There can be only one root screen,
and it is labeled 0.

Note:  If no screen has the label 0, the title begins playing at the first screen
listed in the Screens pane of the Browser miniwindow.

To assign a label to a screen, follow these steps:

1 Click the Selection tool in the Tool palette.

2 Click the Intro screen in the Map window.

The Intro screen is selected.

3 Choose Root from the Label menu.

The label appears beneath the name field of the Intro screen in the Map
window. When your title begins playing, the Intro screen will be the first
screen to appear.
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Connecting screens

The connections between screens in the Map window define the ways in
which the user can navigate screens when the title is playing.

To connect the screens, follow these steps:

1 Double-click the Connection tool in the Tool palette.

The pointer takes the shape of the Connection tool symbol.

Shortcut:  Another way to change the pointer to the Connection tool is to hold
down the Option key while the pointer is over the Map window.

2 Place the pointer over the name field of the Intro screen.

3 Drag from the Intro Screen to the name field of the Main screen.

A new connection forms between the Intro and Main screens, with the arrow
of the connection pointing toward the Main screen.
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4 Using the same technique, add a second connection from the Main screen back to the
Intro screen.

A second arrow appears on the connection. This arrow points back toward
the Intro screen.

5 Connect the other screens as shown. 

Notice that some screens are connected in both directions.

If you add a connection between two screens by mistake, click the Cut
Connection tool in the Tool palette and then click the connection you want to
remove.

Shortcut:  Another way to change the pointer to the Cut Connection tool is to
hold down Option-x while the pointer is over the Map window.
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Naming and saving your project

To name and save your new project, follow these steps:

1 Choose Save from the File menu.

A dialog box appears.

2 Click New.

Another dialog box appears, prompting you for the name of the new folder in
which to place your new project.

3 Type TUTORIAL.

4 Click Create.

The dialog box disappears. You have created a new folder named TUTORIAL
on your hard disk.

5 Type Journey to India.

6 Click Save.

The dialog box disappears. Your project is saved in a file named Journey to
India in a folder named TUTORIAL.

Adding media to a project

Before you can begin incorporating media into your design, you need to add
the media to your project. Adding media to your project means that you are
making those media available for your project to use. Although you will add
media in this section, you will not actually use the media until you begin
adding objects to screens later in this chapter.

When you add media to your project, you actually add references to the media
rather than adding the media themselves. The actual media are contained
within files that remain separate from the project files that use them.
Consequently, a project on one hard disk can use media on a different hard
disk or a CD-ROM disc.
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You are going to use the media items that are used by the Journey to India
sample project provided on the Apple Media Tool 2.0 disc. The media you need
are in the MEDIA folder of the Journey to India sample project on that disc.

To add media items, follow these steps:

1 Choose Add from the Media menu.

A dialog box appears.

Shortcut:  Another way to open the dialog box for adding media is to double-
click in an empty area within the Media miniwindow.

2 Locate the MEDIA folder on the Apple Media Tool 2.0 disc.

3 Click the Add All Media In This Folder checkbox.

4 Click Add.

The media are added to the Media miniwindow.

Note:  Another way to add a media item to the Media miniwindow is to drag
the media item’s icon from the desktop to the Media miniwindow.
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Adding objects and interactivity to the Intro screen

Once you have designed the map for your project and added the media you
intend to use, you can begin to add objects to the screens and add interactivity
to each object that requires it. In this section you will add objects and
interactivity to the first screen that appears when your title plays.

Adding objects to the Intro screen

Some types of objects use media from the Media miniwindow and other
types of objects use no media. For example, a Picture object and a Picture
Scroller object both use a Picture media item; a Color object or an Empty
object doesn’t use any media.

As you build this sample project, be sure to create the objects for each screen
in the order presented in the chapter. The order in which you create the
objects on a screen establishes how they are layered on the screen, which in
turn can affect their sensitivity to mouse activity. Objects are layered back to
front, one object per layer, according to the order in which you create them.
You can reorder this layering at any time. The order in which objects are
listed in the Browser miniwindow reflects the current object layering. The
object that is furthest back in the layering is listed first.

Object 1
Background
picture

Object 2
Picture

Object 3
Text

Object 4
Picture

Complete
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The Intro screen requires the following objects:

m BlackBackground

This is a Color object that acts as a background. It presents a black
rectangle that fills the screen.

m TitleName

This is a Picture object using a Picture media item that presents the text
“Journey to India.”

m TajMahal

This is a Picture object using a Picture media item that presents a
photograph of the Taj Mahal and some descriptive text.

Creating the object BlackBackground 

To create the object BlackBackground, follow these steps:

1 Click the Selection tool in the Tool palette.

2 Click the Intro screen.

3 Choose Display: Journey to India - Intro from the Window menu.

The empty Display window for the Intro screen opens.

Shortcut:  Another way to open the Display window for a screen is to double-
click the screen in the Map window.

4 Click the Creation tool in the Tool palette.

The pointer takes the shape of the Creation tool.
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5 Drag diagonally from the middle of the Display window.

A bounding box surrounds a new Empty object in the Display window. A
new item named Empty 1 appears in the Objects pane of the Browser
miniwindow.

IMPORTANT  Using objects with no media minimizes the media files your title
must reference as it plays. As a result, your title may perform better because it
will spend less time reading information from the location where the media
are stored.

6 Press and hold down the mouse button over the object Empty 1 in the Browser
miniwindow.

A pop-up menu appears with Empty selected. The pop-up menu lists the
various types of Empty objects.

7 Choose Color.

The object changes from an Empty object to a Color object. Its name changes
to Color 1.
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8 Choose Parameters from the Edit menu.

A dialog box appears. The background color is set to black. The Shown
checkbox is selected, meaning that when the title begins playing, the object
will be visible when the Intro screen appears. Later in this chapter, you will
deselect this checkbox for the other objects on the Intro screen so that they
remain invisible for a brief time after the Intro screen appears.

9 Type BlackBackground in the Name field.

10 Type 0 in both the X and Y coordinate fields. 

This means that the top-left corner of the object is placed at the top-left
corner of the screen.

11 Type 640 in the Width field and 480 in the Height field.

12 Type 300 in the Duration field.

This sets a clock for the object that will run for 300 ticks, equal to 5 seconds. 

Note:  When you add interactivity to this object, you will use its duration to
control the time at which the Intro screen changes to the Main screen.

13 Click OK.

Color 1 changes to BlackBackground in the Objects pane of the Browser
miniwindow.
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Creating the object TitleName 

To create the object TitleName, follow these steps:

1 Drag the media item S1_INTRO.PIC from the Media miniwindow to the Display window.

If you hold down the mouse button and wait rather than dragging
immediately, a pop-up menu appears and you will be unable to drag the
media item out of the Media miniwindow. If this occurs, release the mouse
button and try again. 

An object is created for the Intro screen. A bounding box appears around the
new object in the Display window for the Intro screen. The object is filled
automatically with the media item S1_INTRO.PIC and then resized to fit the
media item. 

In addition, an item named S1_INTRO.PIC appears in the Objects pane of
the Browser miniwindow. A newly created object that uses a media item
receives the same name as the media item.

Note:  Another way to create an object for a screen is to drag a media item
from the Media miniwindow to the screen in the Screens pane of the Browser
miniwindow.

2 Choose Parameters from the Edit menu.

A dialog box appears.

Shortcut:  Another way to open the dialog box for setting parameters for an
object is to double-click the object in the Browser miniwindow.

3 Type TitleName in the Name field.

4 Type 17 in the X coordinate field and type 10 in the Y coordinate field. 

5 Click the Shown checkbox.

The checkbox changes from selected to deselected. This means that when the
title begins playing, the object TitleName will be invisible when the Intro
screen appears.
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6 Click OK.

The dialog box disappears. The object TitleName moves to its new position in
the Display window. 

Creating the object TajMahal 

To create the object TajMahal, follow these steps:

1 Drag the media item S1_TAJ.PIC from the Media miniwindow to the Display window.

The object S1_TAJ.PIC is created for the Intro screen.

2 Choose Parameters from the Edit menu.

3 Type TajMahal in the Name field.

4 Type 46 in the X coordinate field and 103 in the Y coordinate field.

5 Click the Shown checkbox.

The checkbox changes from selected to deselected. 

6 Click OK.

The object TajMahal moves to its new position in the Display window. 
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7 Choose Close from the File menu.

The Display window disappears.

8 Choose Save from the File menu.

Your work is saved.

Adding interactivity to the Intro screen

Once you have added objects to a screen, you can specify how the objects
behave while the title is playing. You can make an object do nothing more
than appear on the screen when the screen appears. You can also make an
object exhibit special behavior in response to particular events that occur
while the title is playing. To make an object exhibit special behavior, you
begin by defining the events to which it responds. For example, you could
make an object sensitive to a mouse click.

Some events, such as those related to mouse operations, result from user
activity. Other events, such as the event that occurs when a movie finishes
playing, do not result from user activity. In this chapter, specifying that an
object responds to either type of event is referred to as adding interactivity to
the object.

Once you have defined the events to which an object responds, you define the
actions that are performed when the event occurs. For each action, you
specify an object, known as the target, that performs it. The target can be the
object that responds to the event or some other object. For example, you can
specify that an object produces a sound if the user clicks it with the mouse, or
you can specify that a different object produces the sound. An action appears
crossed out in the Actions pane of the Browser if you haven’t specified its
target or if the target you specify can’t perform the action.

There are three types of actions. The first is a command. Commands control
various aspects of screens and objects, such as their visibility or
responsiveness to user activity. For example, you can specify a command that
changes the state of an object from invisible to visible or a command that
changes the state of a disabled object so that it becomes enabled to respond to
mouse clicks.
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The second type of action is a link. Links control which screen appears next
after the current screen disappears. The screen that appears next is known as
the destination of a link. The destination of a link can be specified in several
ways, but in this chapter you will specify the destination only by screen name.
For an object on one screen to be linked to another screen by name, the Map
window must show a connection that points from the former screen to the
latter screen. When a link fails to reflect the screen connections in the Map
window, it appears crossed out in the Actions pane of the Browser
miniwindow.

The third type of action is an effect. Effects control the manner in which
objects appear or disappear on the screen. For example, you can apply an
effect that gives the illusion that the objects on one screen are being wiped
away, revealing the next screen underneath. The impact of an effect is not
seen until the screen is refreshed, at which point the effect applies to the areas
of the screen that have changed in appearance. 

Finally, when two objects physically overlap on the screen, the object in the
background cannot detect mouse activity within the areas covered by the
object in the foreground. Be sure to layer your objects carefully so that the
objects that need to detect mouse activity can do so.

The Intro screen is the first screen to appear when the title begins playing. It
shows for several seconds before causing the next screen to appear. It does
not respond to user activity.
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Adding interactivity to object BlackBackground

When the Intro screen appears, the object BlackBackground appears and
begins playing music that will continue through the appearance of the next
screen. This object will respond only to events that are unrelated to user
activity.

To make the object BlackBackground behave in this way, follow these steps:

1 Click the object BlackBackground in the Objects pane of the Browser miniwindow.

2 Choose Add Event from the Action menu.

The menu command Add Event adds the next possible event that does not yet
appear in the Events pane of the Browser miniwindow. When the Events pane
is empty, this command adds the Before Display event. The next few steps of
this section describe how to define a different event.

The Before Display event occurs immediately before a screen in a title
appears. You will replace Before Display with After Display because the
object BlackBackground needs to perform actions only after the screen
appears. 
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3 Press Before Display.

A pop-up menu appears.

4 Choose After Display.

Before Display changes to After Display. The After Display event occurs
immediately after the screen appears.

5 Choose Add Command from the Action menu.

The menu command Add Command always adds the Enable command to the
Actions pane of the Browser miniwindow. The next few steps of this section
describe how to define a different command. 
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Note:  The menu commands Add Effect and Add Link, which you will use
later in this chapter, are similar to Add Command. Add Effect always adds the
effect called No Effect. Add Link always adds the Go To link.

Shortcut:  Another way to add a command is to double-click an empty area
within the Actions pane of the Browser miniwindow. 

The Enable command, whose initial target is the current object itself, enables
an object to interact with user events such as mouse clicks. In this title the
object BlackBackground does not take part in any interactivity with the user,
so it does not need to enable itself. However, it does need to start its clock, so
you will replace the Enable command with the Start command. 

6 Press Enable Itself.

A pop-up menu appears.

7 Choose Start.

Enable Itself changes to Start Itself.

8 Choose Add Command from the Action menu.

Enable Itself appears in the Actions pane of the Browser miniwindow. 

In this title the object BlackBackground needs to start playing a sound that
will continue through the appearance of the next screen. The Start Ambient
Sound command makes this behavior possible, so you will replace the Enable
command with the Start Ambient Sound command.
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9 Replace the Enable command with the Start Ambient Sound command.

Enable Itself changes to Start Ambient Sound. At first, Start Ambient Sound
is crossed out. This means that you must specify a target whose sound it will
start.

10 Drag the media item S1_AMSND.WAV from the Media miniwindow to Start Ambient
Sound in the Actions pane of the Browser miniwindow.

Start Ambient Sound becomes highlighted as you drag the media item to it.
This informs you that media item S1_AMSND.WAV is an acceptable target
for this command.

Start Ambient Sound changes to Start Ambient Sound S1_AMSND.WAV and
is no longer crossed out. You can resize the Browser miniwindow to display
the target clearly.

11 Choose Add Event from the Action menu.

Before Display appears in the Events pane of the Browser miniwindow, and
the Actions pane becomes empty. 

The Intro screen needs to be linked to the Main screen when the clock for
object BlackBackground finishes running, so you will replace Before Display
with the Finished event. 
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12 Replace Before Display with the Finished event.

Before Display changes to Finished. The Finished event occurs when the
clock for an object has run for the specified duration.

13 Choose Add Effect from the Action menu.

No Effect 30 appears in the Actions pane of the Browser miniwindow. The
initial duration of an effect is 30 ticks.

Shortcut:  Another way to add an effect is to Option–double-click an empty
area within the Actions pane of the Browser miniwindow.

As its name suggests, No Effect applies no special visual effect to the changed
areas of the screen the next time the screen is refreshed. In this title, the next
screen refresh will occur when the Intro screen links to the Main screen. The
title needs to give the illusion that the Intro screen is being wiped away as the
Main screen appears, so you will replace No Effect 30 with Wipe Top 30. 

14 Press No Effect 30.

A pop-up menu appears.
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15 Choose Wipe Top.

No Effect 30 changes to Wipe Top 30. The Intro screen will appear to be
wiped away from top to bottom.

16 Choose Add Link from the Action menu.

Go To Itself appears in the Actions pane of the Browser miniwindow. The
initial destination of a Go To link is the current screen itself.

Shortcut:  Another way to add a link is to Option–x–double-click an empty
area within the Actions pane of the Browser miniwindow.

The Go To link makes its destination screen appear. In this title the Main
screen needs to appear after the Intro screen, so you will change the
destination of the Go To link from Itself to Main. 

17 Drag the Main screen from the Screens pane of the Browser miniwindow to Go To Itself
in the Actions pane of the Browser miniwindow.

Go To Itself becomes highlighted as you drag the Main screen over it. This
informs you that the Main screen is an acceptable destination for this link.
After you release the mouse button, Go To Itself changes to Go To Main.

Shortcut:  To add a link from one screen to another screen when you have not
yet created a connection in the Map window from the former to the latter
screen, hold down the Control key while dragging the destination screen from
the Screens pane to the Go To link in the Actions pane of the Browser
miniwindow. This adds a link and creates a corresponding connection
simultaneously.
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Adding interactivity to object TitleName

Shortly after the Intro screen appears, the object TitleName will appear with
a special visual effect. It will respond only to events that are unrelated to user
activity.

To make the object TitleName behave in this way, follow these steps:

1 Click the object TitleName in the Objects pane of the Browser miniwindow.

2 Choose Add Event from the Action menu.

Before Display appears in the Events pane of the Browser miniwindow.

3 Replace Before Display with After Display.

4 Choose Add Command from the Action menu.

Enable Itself appears in the Actions pane of the Browser miniwindow. 

When you created the object TitleName earlier in this chapter, you deselected
its Shown parameter so that it would remain invisible until it received an
explicit command to become visible. In this title the object TitleName needs
to become visible shortly after the screen appears, so you will replace the
Enable command with the Show command. 

5 Replace the Enable command with the Show command.

Enable Itself changes to Show Itself. The Show command makes an invisible
object visible the next time the screen is refreshed. The initial target of a
Show command is the current object itself.

6 Choose Add Effect from the Action menu.

No Effect 30 appears in the Actions pane of the Browser miniwindow. 

7 Replace No Effect with the Wipe Left effect.

No Effect 30 changes to Wipe Left 30. The object TitleName will appear to
be wiped onto the screen from left to right as it becomes visible. You will
modify this effect so that it takes more time to complete. 



8 Choose Parameters from the Edit menu.

A dialog box appears.

9 Type 40 in the Duration field.

10 Click OK.

Wipe Left 30 changes to Wipe Left 40.

11 Choose Add Command from the Action menu.

Enable Itself appears in the Actions pane of the Browser miniwindow. 

When the title plays, the object TitleName needs to become visible before the
object TajMahal becomes visible. Forcing the screen to refresh immediately
after the Show command and Wipe Left effect will achieve this, so you will
replace the Enable command with the Refresh command.

12 Replace the Enable command with the Refresh command.

Enable Itself changes to Refresh. The Refresh command will update all areas
of the screen that have changed since the last screen refresh.

Apple Media Tool refreshes the screen automatically after all actions for a
particular event have been performed. The Refresh command allows you to
override this automatic behavior. If you were to omit the Refresh command
for object TitleName, the objects TitleName and TajMahal would appear
simultaneously after all three objects on the Intro screen had responded to the
After Display event.

Adding interactivity to object TajMahal

Shortly after the object TitleName appears on the Intro screen, the object
TajMahal will appear with a special visual effect. It will respond only to
events that are unrelated to user activity.
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To make the object TajMahal behave in this way, follow these steps:

1 Click the object TajMahal in the Objects pane of the Browser miniwindow.

2 Choose Add Event from the Action menu.

Before Display appears in the Events pane of the Browser miniwindow.

3 Replace Before Display with After Display.

4 Choose Add Command from the Action menu.

Enable Itself appears in the Actions pane of the Browser miniwindow.

When you created the object TajMahal earlier in this chapter, you deselected
its Shown parameter so that it would remain invisible until it received an
explicit command to become visible. When the title plays, the object TajMahal
needs to become visible shortly after the object TitleName appears, so you
will replace the Enable command with the Show command. 

5 Replace the Enable command with the Show command.

Enable Itself changes to Show Itself.

6 Choose Add Effect from the Action menu.

No Effect 30 appears in the Actions pane of the Browser miniwindow. 

7 Replace No Effect with the Iris Open effect.

No Effect 30 changes to Iris Open 30. Now when the screen is refreshed, the
object TajMahal will look as if a camera lens is opening over it.

Using the Run command to preview the Intro screen

After you have finished adding interactivity to the Intro screen, you can use
the Run command to preview how the Intro screen will behave at playback
once it is compiled into a title.
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To preview the behavior of the Intro screen, follow these steps:

1 Click the Intro screen in the Screens pane of the Browser miniwindow.

The Intro screen is selected. The Run command previews the title beginning
with the selected screen. If no screens are selected, the Run command is
disabled.

2 Choose Run from the Window menu.

The project begins playing and the Intro screen appears.

Shortcut:  Another way to execute the Run command is to press x-T.

3 Press x-period.

The project stops playing and you return to the Apple Media Tool authoring
environment.

As you build the remaining screens in this chapter, use the Run command to
preview your work.

Adding objects and interactivity to the Main screen

In this section, you will add objects and interactivity to the Main screen of
your title. The Main screen will present three photographs that you can click
to view the screens containing more information on Rajasthan, Varanasi, and
Darjeeling.
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Adding objects to the Main screen

The Main screen requires the following objects:

m BackgroundPicture

This is a Picture object that uses a Picture media item for a background
graphic, the name of the title, and the buttons in the lower-left and lower-
right corners of the screen. BackgroundPicture provides the background for
the screen. 

m ClickSound

This is a Sound object that uses a Sound media item. It produces a click
sound when it plays. It is used as a button and as the target of a command.

m ExitButton

This is a Picture object that uses a Picture media item for an exit button.

m ScrollingText

This is a Text Scroller object that uses a Text media item for informational
text in a scrolling pane.

m PictureFrame

This is a Picture object that uses a Picture media item for a photograph
frame. Three PictureFrame objects will be created, one for each
photograph on this screen.

m CamelPicture

This is a Picture object that uses a Picture media item for a photograph of a
camel.

m LandscapePicture

This is a Picture object that uses a Picture media item for a photograph of a
landscape.

m BoatPicture

This is a Picture object that uses a Picture media item for a photograph of 
a boat.
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Creating the object BackgroundPicture

To create the object BackgroundPicture, follow these steps:

1 Double-click the Main screen in the Map window.

The empty Display window for the Main screen opens.

2 Drag the media item S2_MSRN.PIC from the Media miniwindow to the Display window.

The object S2_MSRN.PIC is created for the Main screen.

3 Choose Parameters from the Edit menu.

A dialog box appears.

4 Type BackgroundPicture in the Name field.

5 Click the Enabled checkbox.

The checkbox changes from selected to deselected. 

When the Main screen appears, the object BackgroundPicture will be
insensitive to user activity. The pointer will take the shape of the Disabled
symbol when it is positioned over this object in the screen.

6 Click OK.

The dialog box disappears.

7 Choose Lock from the Object menu.
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A lock symbol appears next to the object in the Objects pane of the Browser
miniwindow.

Tip:  It is good practice to lock the background of a screen so that you can’t
move it inadvertently while you’re moving other objects in the Display
window.

Creating the object ClickSound 

To create the object ClickSound, follow these steps:

1 Drag the media item S2_CLK.WAV from the Media miniwindow to the Display window.

The object S2_CLK.WAV is created for the Main screen. The media item
S2_CLK.WAV has no visual components, so the object appears as an empty
bounding box. 

2 Change the name of object S2_CLK.WAV to ClickSound.

3 Drag the object ClickSound in the Display window to the button picture in the lower-right
corner of the Display window.

The object ClickSound overlaps the button picture.

Overlapping this area of the screen with the object ClickSound makes this
area sensitive to user activity. When the user positions the pointer over this
area of the screen, the pointer will take the shape of the Enabled symbol.
When the user clicks this area of the screen, the object ClickSound will
respond. Because the media item for object ClickSound has no visual
components, the button picture shows through.
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3 Choose Text Scroller.

The Text object changes to a Text Scroller object. When this object appears, it
will be in a scrolling pane.

4 Double-click the object S2_RTF.TXT in the Objects pane of the Browser miniwindow.

A dialog box appears.

5 Type ScrollingText in the Name field.

6 Type 270 in the X coordinate field and 105 in the Y coordinate field. 

7 Type 305 in the Width field and 110 in the Height field.

Shortcut:  Another way to resize an object in the Display window is to drag its
corner handles.

8 Click the Background checkbox.

The checkbox changes from selected to deselected. 

This makes the background behind the text transparent so that objects behind
it will show through.

9 Click OK.

Creating three PictureFrame objects

IMPORTANT  Copying and pasting an object is a fast and efficient way to create
several identical objects. Objects created in this manner share a single media
item, which minimizes the number of media items your title must access.

To create three copies of the object PictureFrame, follow these steps:

1 Drag the media item S2_FRM.PIC from the Media miniwindow to the Display window.

2 Double-click the object S2_FRM.PIC in the Objects pane of the Browser miniwindow.

A dialog box appears.

3 Type PictureFrame in the Name field.

4 Type 77 in the X coordinate field and 110 in the Y coordinate field. 

5 Click OK.
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6 Choose Copy from the Edit menu.

7 Choose Paste from the Edit menu.

A copy of object PictureFrame overlaps the original.

8 Choose Paste from the Edit menu again.

A second copy of object PictureFrame overlaps the first copy.

9 Move the top two copies of PictureFrame as shown.

You can see all three objects at once.

10 Select the original object PictureFrame and the bottom-left copy by holding down the
Shift key and clicking each object.

Be sure that these are the only selected objects. If you select another object,
such as the background, by mistake, you can deselect it by holding down the
Shift key while clicking the object.
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11 Choose Align from the Object menu.

A dialog box appears.

12 Make the choices shown in the dialog box.
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13 Click OK.

The copy of object PictureFrame aligns horizontally with the left edge of the
original object.

14 Select the bottom-left copy of object PictureFrame and the copy to its right.

Be sure these are the only selected objects.

15 Choose Align from the Object menu.

A dialog box appears.

16 Make the choices shown in the dialog box.
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17 Click OK.

The objects align vertically with the bottom edge of the lower copy of the
object.

Creating the object CamelPicture

To create the object CamelPicture, follow these steps:

1 Drag the media item S2_CAM.PIC from the Media miniwindow to the Display window.

2 Center this object over the object PictureFrame at the top left.

3 Change the name of object S2_CAM.PIC to CamelPicture.

Creating the object LandscapePicture

To create the object LandscapePicture, follow these steps:

1 Drag the media item S2_DAR.PIC from the Media miniwindow to the Display window.

2 Center this object over the object PictureFrame at the bottom right.

3 Change the name of object S2_DAR.PIC to LandscapePicture.
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Creating the object BoatPicture

To create the object BoatPicture, follow these steps:

1 Drag the media item S2_BOAT.PIC from the Media miniwindow to the Display window.

2 Center this object over the object PictureFrame at the bottom left.

3 Change the name of object S2_BOAT.PIC to BoatPicture.

Your pictures should look like this.

Adding interactivity to the Main screen

When the title is playing, the Main screen is the first screen that responds to
user activity. The user can go from this screen to the more detailed
information in the Rajasthan, Varanasi, and Darjeeling screens.

Adding interactivity to object ClickSound

When the Main screen appears, the object ClickSound will overlap the lower-
right button picture, making the button picture appear to respond to user
activity. When the user clicks this area of the screen, the object ClickSound
will produce a click sound and make the Rajasthan screen appear.
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To add interactivity to the object ClickSound, follow these steps:

1 Add the Mouse Up event to the object ClickSound.

The Mouse Up event will occur when the user clicks the object ClickSound.

2 Add the Start command to the Mouse Up event.

Start Itself will make the object ClickSound produce its sound.

3 Add Wipe Top 30 to the Mouse Up event.

The Wipe Top effect will apply to the changed areas of the screen when the
Rajasthan screen appears. 

4 Add Go To Rajasthan to the Mouse Up event.

This completes the definition of the behavior for object ClickSound. You can
copy and paste this object into any screen that requires the same behavior.
Since the Main screen needs both a lower-left and a lower-right button, you
will copy and paste the object ClickSound over the lower-left button picture
on this screen.

5 Click the object ClickSound in the Display window.

6 Choose Copy from the Edit menu.

7 Choose Paste from the Edit menu.

A copy of object ClickSound overlaps the original. A second object named
ClickSound appears at the end of the list in the Objects pane of the Browser
miniwindow. When you copy and paste an object, the copy automatically
receives the same name as the original. 

Tip:  Within a screen, you can distinguish between objects that have the same
name by selecting each instance of the object in the Objects pane of the
Browser miniwindow and then observing which object is surrounded by a
bounding box in the Display window for that screen.

8 Change Go To Rajasthan to Go To Intro for the copy of object ClickSound.

This will be the only behavioral difference between the original and the copy
of the object ClickSound.
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9 Hold down the Shift key and drag the copy of object ClickSound over the button picture
in the lower-left corner of the Display window.

The copy of object ClickSound overlaps the button picture.

Holding down the Shift key while dragging an object to the left or to the right
of its current position in the Display window constrains its movement along
the X-axis. Holding down the Shift key while dragging an object up or down
constrains its movement along the Y-axis.

10 In the Objects pane of the Browser miniwindow, drag the copy of the object ClickSound
upward until the horizontal line that appears is between the objects ExitButton and
ScrollingText.

The copy of object ClickSound is inserted between the objects ExitButton
and ScrollingText. This means that the copy of object ClickSound is layered
between the objects ExitButton and ScrollingText.

Note:  Another way to change an object’s layer is to select the object in the
Objects pane of the Browser miniwindow and then choose a command from
the pull-down menu above the vertical scroll bar for the Objects pane.

Adding interactivity to object ExitButton

When the title is playing and the Main screen appears, clicking this object
will quit the title.

To add interactivity to the object ExitButton, follow these steps:

1 Add the Mouse Up event to the object ExitButton.

2 Add the Quit link to the Mouse Up event.

The Quit link requires no destination.
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Adding interactivity to object ScrollingText

When the Main screen appears, the object ScrollingText will present some
informational text in a scrolling pane. Clicking the blue word Rajasthan,
Varanasi, or Darjeeling will make the screen of the same name appear.

Note:  A series of characters within a Text object that can trigger one or more
actions when you click it is known as hot text. Hot text can be used like a
button or to implement hypertext. When a Rich Text Format (RTF) file is
used as a Text media item, any series of characters that has the Strikethru
style applied to it is interpreted as hot text by the Text object using the media
item. The Strikethru style is invisible to the user once the Text object appears
on the screen. Therefore, to ensure that hot text is easily identifiable on the
screen, a color or other distinctive style should be applied in addition to the
Strikethru style during media creation.

To add interactivity to the object ScrollingText, follow these steps:

1 Add the Hot Text event to the object ScrollingText.

Hot Text appears in the Events pane of the Browser miniwindow. Initially, the
Hot Text event specifies no text.

2 Double-click the Hot Text event.

A dialog box appears, prompting you to choose from a list of words. 

These are the words that the Text media item has defined as hot. Because this
list reflects information maintained in the Text media item, you cannot add
words to the list or modify the existing words in the list from this dialog box.
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3 Click Rajasthan.

Rajasthan is selected.

4 Click OK.

Hot Text changes to Hot Text Rajasthan. This event will occur when the user
clicks the blue word Rajasthan in the object ScrollingText.

5 Add Start ClickSound to Hot Text Rajasthan.

Start ClickSound will make the object ClickSound play its sound.

6 Add Wipe Top 30 to Hot Text Rajasthan.

The Wipe Top effect will apply to the changed areas of the screen when the
Rajasthan screen appears. 

7 Add Go To Rajasthan to Hot Text Rajasthan.

This completes the definition of the first of three Hot Text events. You can
copy and paste this event into any Text object or Text Scroller object that
requires the same event. Since the object ScrollingText contains three
occurrences of hot text, you will copy this event and paste it two more times
into the Events pane for object ScrollingText.

8 Click Hot Text Rajasthan.

9 Choose Copy from the Edit menu.

10 Choose Paste from the Edit menu.

A copy of Hot Text Rajasthan appears in the Events pane of the Browser
miniwindow.

11 Choose Paste from the Edit menu once more.

Another copy of Hot Text Rajasthan appears in the Events pane of the
Browser miniwindow.

12 Change the first copy of Hot Text Rajasthan to Hot Text Varanasi.

13 Change the second copy of Hot Text Rajasthan to Hot Text Darjeeling.

14 Change Go To Rajasthan to Go To Varanasi for Hot Text Varanasi.
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To add interactivity to the object LandscapePicture, follow these steps:

1 Click the object CamelPicture in the Objects pane of the Browser miniwindow.

2 Click Mouse Up in the Events pane of the Browser miniwindow.

3 Choose Copy from the Edit menu.

4 Click the object LandscapePicture in the Objects pane of the Browser miniwindow.

5 Choose Paste from the Edit menu.

A copy of Mouse Up appears in the Events pane of the Browser miniwindow.

6 Change Go To Rajasthan to Go To Darjeeling.

Adding interactivity to object BoatPicture

When the Main screen appears, the object BoatPicture will appear. When the
user clicks the object BoatPicture, the object will produce a click sound and
make the Varanasi screen appear. You will copy the event defined for the
object CamelPicture and paste it to the object BoatPicture to quickly
implement this behavior.

To add interactivity to the object BoatPicture, follow these steps:

1 Click the object CamelPicture in the Objects pane of the Browser miniwindow.

2 Click Mouse Up in the Events pane of the Browser miniwindow.

3 Choose Copy from the Edit menu.

4 Click the object BoatPicture in the Objects pane of the Browser miniwindow.

5 Choose Paste from the Edit menu.

A copy of Mouse Up appears in the Events pane of the Browser miniwindow.

6 Change Go To Rajasthan to Go To Varanasi.
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Adding objects and interactivity to the Rajasthan screen

In this section you will add objects and interactivity to the screen that
contains more information about Rajasthan.

Adding objects to the Rajasthan screen

The Rajasthan screen requires the following objects, the first three of which
are used by the Main screen as well:

m BackgroundPicture

This Picture object uses a Picture media item and provides the background
for the screen.

m ClickSound

This Sound object uses a Sound media item and produces a click sound
when it plays. It is used as a button.

m ExitButton

This Picture object uses a Picture media item for an exit button.

m MouseMoveInstruction

This Text object uses a Text media item for an instruction to the user.

m AjmerMovie

This Movie Controller object uses a Movie media item for a movie of the
city of Ajmer. The movie appears within a movie controller when the user
moves the mouse over a hot region on the screen.

m JaisalmerPicture

This Picture object uses a Picture media item for a photograph of the city
of Jaisalmer. It appears when the user moves the mouse over a hot region
on the screen.

m RajasthanMap

This Picture object uses a Picture media item for a map of Rajasthan. It is
sensitive to mouse activity only within a small rectangular hot region.
Moving the mouse within this hot region causes the photograph of the city
of Jaisalmer to appear.



m AjmerHotRegion

This Empty object overlaps a portion of the object RajasthanMap. It
defines a second hot region on the map of Rajasthan. Moving the mouse
within this object causes the movie of the city of Ajmer to appear.

Creating the objects BackgroundPicture, ClickSound, ExitButton, and ClickSound

To create these objects all at once, follow these steps:

1 Click the Main screen in the Screens pane of the Browser miniwindow.

2 Hold down the Shift key and click the objects BackgroundPicture, ClickSound,
ExitButton, and ClickSound in the Objects pane of the Browser miniwindow.

All four objects are selected. 

You need to duplicate these objects for the Rajasthan screen. Earlier you used
the menu commands Copy and Paste to duplicate items in the Browser
miniwindow. This time you will duplicate items by dragging them between
the panes of the Browser miniwindow.

3 Drag the selected objects to Rajasthan in the Screens pane of the Browser miniwindow.

Rajasthan becomes highlighted as you drag the objects over it. This informs
you that this operation is acceptable. When you release the mouse button,
these objects are duplicated for the Rajasthan screen.

Creating the object MouseMoveInstruction

To create the object MouseMoveInstruction, follow these steps:

1 Double-click the Rajasthan screen in the Map window.

The Display window for the Rajasthan screen opens.

2 Drag the media item S3_OVER.TXT from the Media miniwindow to the Display window.
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3 Using the corner handles, resize the object S3_OVER.TXT to make it the size shown.

4 Reposition the object S3_OVER.TXT as shown.

5 Change the name of object S3_OVER.TXT to MouseMoveInstruction.

Creating the object AjmerMovie

To create the object AjmerMovie, follow these steps:

1 Drag the media item S3_AJ.MOV from the Media miniwindow to the Display window.

2 Press the object S3_AJ.MOV in the Objects pane of the Browser miniwindow.

A pop-up menu appears. The pop-up menu lists the various types of Movie
objects.

3 Choose Movie Controller.

The Movie object changes to a Movie Controller object. When this object
appears, it will do so in a movie controller.

4 Double-click the object S3_AJ.MOV in the Objects pane of the Browser miniwindow.

A dialog box appears.

5 Type AjmerMovie in the Name field.
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6 Type 327 in the X coordinate field and 116 in the Y coordinate field.

7 Click the Shown checkbox.

The checkbox changes from selected to deselected. 

8 Click OK.

Creating the object JaisalmerPicture

To create the object JaisalmerPicture, follow these steps:

1 Drag the media item S3_JAL.PIC from the Media miniwindow to the Display window.

2 Choose Hide Media from the Object menu.

The object S3_JAL.PIC becomes transparent in the Display window. In
addition, a small symbol appears to the right of the object S3_JAL.PIC in the
Objects pane of the Browser miniwindow. When you are manipulating an
object in the Display window, it can be useful to make the object transparent
so that you can see the objects behind it. The impact of the command Hide
Media is restricted to the Display window. Hide Media has no effect on the
object as it appears in a title that is playing.
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3 Reposition the object S3_JAL.PIC as shown.

4 Choose Show Media from the Object menu.

The object S3_JAL.PIC is no longer transparent. It overlaps the object
AjmerMovie. Later in this chapter, you will define actions that make either
one or the other visible at a time.

5 Double-click the object S3_JAL.PIC in the Objects pane of the Browser miniwindow.

A dialog box appears.

6 Type JaisalmerPicture in the Name field.

7 Click the Shown checkbox.

The checkbox changes from selected to deselected.

8 Click OK.

Creating the object RajasthanMap

To create the object RajasthanMap, follow these steps:

1 Drag the media item S3_RMAP.PIC from the Media miniwindow to the Display window.
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2 Reposition the object S3_RMAP.PIC as shown.

3 Change the name of object S3_RMAP.PIC to RajasthanMap.

4 Choose Select Media from the Object menu.

The media item used by the object RajasthanMap becomes selected in the
Media miniwindow.
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5 Double-click the media item S3_RMAP.PIC in the Media miniwindow.

A dialog box appears. 

Notice that this dialog box contains parameters for the media item
S3_RMAP.PIC, not the object RajasthanMap. Any changes you make in this
dialog box will affect all the objects that use this media item. 

6 Click the Transparent checkbox.

The checkbox changes from deselected to selected.

This means that objects behind any object that uses media item
S3_RMAP.PIC will show through the areas of the object that have the
specified color. The values set in the Red, Green, and Blue fields specify the
color.

7 Click Color.

A dialog box appears containing a picture of the media item and a rectangular
color swatch. 

The color swatch indicates the current transparent color. Initially, the color
swatch is white. In the next few steps you will experiment with changing the
color swatch.
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8 Place the pointer over the middle of the map.

The pointer takes the shape of an eyedropper.

9 Click the map.

The color swatch changes from white to the map color. When the pointer is
an eyedropper and you click the picture, the color swatch changes to the color
of the pixel you clicked.

10 Click the white area outside the map.

The color swatch changes back to white.

11 Click OK.

The dialog box containing the color swatch disappears.

12 Click OK.

The dialog box disappears. The white areas of the object RajasthanMap
become transparent in the Display window.

13 Click the Rectangle Hot Region tool in the Tool palette.
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14 Place the pointer slightly above and to the left of the word Jaisalmer on the object
RajasthanMap, and drag diagonally across the word Jaisalmer.

The old bounding box disappears and a new bounding box appears around
the word Jaisalmer. The new bounding box designates the new hot region on
object RajasthanMap, and drag diagonally across the word Jaisalmer.

Note:  You can use the Hot Region tools to define more complex hot regions
than the one you defined for object RajasthanMap. For example, you could
create a hot region with an unusual shape or one that was composed of
several non intersecting areas. Because an object cannot determine which
part of its hot region detected mouse activity, the object will exhibit the same
behavior regardless of where the mouse activity occurred. The Rectangle and
Polygon Hot Region tools define hot regions more efficiently than the other
Hot Region tools, so use them instead of the other tools whenever possible.

Creating the object AjmerHotRegion

AjmerHotRegion is an Empty object that overlaps the object RajasthanMap.
Because Empty objects are transparent, the object RajasthanMap shows
through. AjmerHotRegion functions as an additional hot region over the map.
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To create the object AjmerHotRegion, follow these steps:

1 Click the Creation tool in the Tool palette.

2 Place the pointer slightly above and to the left of the word Ajmer on the object
RajasthanMap, and drag diagonally across the word.

A bounding box surrounds a new Empty object in the Display window.

3 Choose Parameters from the Edit menu.

A dialog box appears.

4 Type AjmerHotRegion in the Name field.

5 Click OK.

Adding interactivity to the Rajasthan screen

When the title is playing, the Rajasthan screen is one of three screens that the
user can view and interact with to obtain more detailed information on India.

Adding interactivity to the lower-right object ClickSound

Earlier in the chapter you copied the lower-right and the lower-left
ClickSound objects from the Main screen into the Rajasthan screen. You need
to modify the lower-right copy so that clicking it makes the Varanasi screen
rather than the Rajasthan screen appear. In addition, you need to modify the
effect this object applies when the new screen appears.
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To modify the interactivity of the lower-right object ClickSound, follow these
steps:

1 Change Wipe Top 30 to Wipe Left 30.

2 Change Go To Rajasthan to Go To Varanasi.

Adding interactivity to the lower-left object ClickSound

You also need to modify the lower-left object ClickSound so that clicking it
returns the user to the Main screen rather than the Intro screen. In addition,
you need to modify the effect this object applies when the new screen
appears.

To modify the interactivity of the lower-left object ClickSound, follow these
steps:

1 Change Wipe Top 30 to Wipe Right 30.

2 Change Go To Intro to Go To Main.

Adding interactivity to object RajasthanMap

When the Rajasthan screen appears, the object RajasthanMap will appear.
When the user moves the pointer over the word Jaisalmer, the object will
make a photograph appear.

To add interactivity to the object RajasthanMap, follow these steps:

1 Add the Mouse Enter event to the object RajasthanMap.

Mouse Enter detects when the user moves the mouse over the hot region for
the object RajasthanMap.

2 Add Hide AjmerMovie to the Mouse Enter event.

Earlier in this chapter, you made the objects JaisalmerPicture and
AjmerMovie overlap. Hide AjmerMovie will make the movie invisible so that
the object JaisalmerPicture can appear in its place.

3 Add Show JaisalmerPicture to the Mouse Enter event.

Show JaisalmerPicture will make the object JaisalmerPicture appear.
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4 Add Iris Open 30 to the Mouse Enter event.

The Iris Open effect will apply to the changed area of the screen when object
AjmerMovie disappears and object JaisalmerPicture appears in its place.

Adding interactivity to object AjmerHotRegion

When the Rajasthan screen appears, the object AjmerHotRegion will appear
transparent, enabling the map it overlaps to show through. When the user
moves the pointer over the word Ajmer on the map, the object
AjmerHotRegion will intercept this mouse activity and make a movie appear. 

The purpose of object AjmerHotRegion is to create the illusion that the object
RajasthanMap has two hot regions, each of which exhibits unique behavior
when it detects mouse activity.

To add interactivity to the object AjmerHotRegion, follow these steps:

1 Add the Mouse Enter event to the object AjmerHotRegion.

2 Add Hide JaisalmerPicture to the Mouse Enter event.

Earlier in this chapter, you made the objects JaisalmerPicture and
AjmerMovie overlap. Hide JaisalmerPicture will make the picture invisible so
that the movie can appear in its place.

3 Add Show AjmerMovie to the Mouse Enter event.

Show AjmerMovie will make the movie appear.

4 Add Iris Open 30 to the Mouse Enter event.

The Iris Open effect will apply to the changed area of the screen when object
JaisalmerPicture disappears and object AjmerMovie appears in its place.
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Adding objects and interactivity to the Varanasi screen

In this section you will add objects and interactivity to the screen that
contains more information about Varanasi.

Adding objects to the Varanasi screen

The Varanasi screen requires the following objects, the first three of which
are used by the Rajasthan screen as well:

m BackgroundPicture

This Picture object uses a Picture media item and provides the background
for the screen.

m ClickSound

This Sound object uses a Sound media item and produces a click sound
when it plays. It is used as a button.

m ExitButton

This Picture object uses a Picture media item for an exit button.

m WomanNearRiver

This Picture object uses a Picture media item for a photograph of a woman
standing near a river. This is visible when the picture to its left is not
visible. The user switches between the two pictures by holding down the
mouse button while the pointer is within the picture.

m PeopleNearRiver

This Picture object uses a Picture media item for a photograph of people
standing near a river. It is visible only when the picture to its right is not
visible. 

m MouseDownInstruction

This Text object uses a Text media item for an instruction to the user. It is
visible when the picture of the woman near the river is visible.

m BuildingsPicture

This Picture object uses a Picture media item for a photograph of
buildings. It scrolls within its bounding box when the user drags within it.

m ClickDragInstruction

This Text object uses a Text media item for an instruction to the user.
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Creating the objects BackgroundPicture, ClickSound, ExitButton, and ClickSound

To create these objects all at once, follow these steps:

1 Click the Rajasthan screen in the Screens pane of the Browser miniwindow.

2 Hold down the Shift key and click the objects BackgroundPicture, ClickSound,
ExitButton, and ClickSound in the Objects pane of the Browser miniwindow .

3 Drag the selected objects to Varanasi in the Screens pane of the Browser miniwindow.

All four objects are duplicated for the Varanasi screen.

Creating the object WomanNearRiver

To create the object WomanNearRiver:

m Create an object that uses the media item S4_RIV.PIC, rename the object
WomanNearRiver, and reposition it as shown.
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Creating the object PeopleNearRiver

To create the object PeopleNearRiver, follow these steps:

1 Create an object that uses the media item S4_RIV2.PIC, rename the object
PeopleNearRiver, and reposition it as shown.

2 Choose Parameters from the Edit menu.

3 Click the Shown checkbox.

The checkbox changes from selected to deselected. 
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Creating the object MouseDownInstruction

To create the object MouseDownInstruction:

m Create an object that uses the media item S4_MDWN.TXT, rename the object
MouseDownInstruction, and reposition and resize it as shown.

Creating the object BuildingsPicture

To create the object BuildingsPicture:

m Create an object that uses the media item S4_VAR.PIC, rename the object
BuildingsPicture, and reposition and resize it as shown.
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Creating the object ClickDragInstruction

To create the object ClickDragInstruction:

m Create an object that uses the media item S4_MIN.TXT, rename the object
ClickDragInstruction, and reposition and resize it as shown.

Adding interactivity to the Varanasi screen

When the title is playing, the Varanasi screen is one of three screens that the
user can view and interact with to obtain more detailed information on India.

Adding interactivity to the lower-right object ClickSound

Earlier in the chapter you copied the lower-right and the lower-left
ClickSound objects from the Rajasthan screen into the Varanasi screen. 
Now you need to modify the lower-right copy so that clicking it makes the
Darjeeling screen rather than the Varanasi screen appear. You do not need 
to modify the lower-left copy because it behaves the same way in both the
Rajasthan and Varanasi screens.

To modify the interactivity of the lower-right object ClickSound:

m Change Go To Varanasi to Go To Darjeeling.
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Adding interactivity to object WomanNearRiver

When the Varanasi screen appears, the object WomanNearRiver will appear.
When the user holds down the mouse button while the pointer is within
object WomanNearRiver, object WomanNearRiver and some text will become
invisible as a previously invisible object appears to the left. When the user
releases the mouse button, the object to the left will become invisible as the
text and object WomanNearRiver appear once again.

To add interactivity to the object WomanNearRiver, follow these steps:

1 Add the Mouse Down event to the object WomanNearRiver.

2 Add Show◊Hide Itself to the Mouse Down event.

If an object is invisible, the Show◊Hide command makes it visible. If an
object is visible, the Show◊Hide command makes it invisible. 

3 Add Show◊Hide PeopleNearRiver to the Mouse Down event.

4 Add Show◊Hide MouseDownInstruction to the Mouse Down event.

5 Add Wipe Right 30 to the Mouse Down event.

6 Click the Mouse Down event.

7 Choose Copy from the Edit menu.

8 Choose Paste from the Edit menu.

The Mouse Down event is crossed out because there is already one defined.

9 Replace Mouse Down with Mouse Up.

The Mouse Up event occurs when the user releases the mouse. You do not
need to modify the Show◊Hide commands you copied from Mouse Down
because Mouse Up can use these commands without modification. You only
need to modify the effect.

10 Change Wipe Right 30 to Wipe Left 30.
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Adding interactivity to object BuildingsPicture

When the Varanasi screen appears, the object BuildingsPicture will appear.
The media item that object BuildingsPicture uses is larger than the object.
When the user drags within this object, the object will scroll within its
bounding box, revealing the areas of the media item that lie outside the
bounding box.

To add interactivity to the object BuildingsPicture, follow these steps:

1 Add the Mouse Moved event to the object BuildingsPicture.

2 Add Scroll Itself to the Mouse Moved event.

Adding objects and interactivity to the Darjeeling screen

In this section you will add objects and interactivity to the screen that
contains more information about Darjeeling.

Adding objects to the Darjeeling screen

The Darjeeling screen requires the following objects, the first three of which
are used by the Rajasthan screen as well:

m BackgroundPicture

This Picture object uses a Picture media item and provides the background
for the screen.

m ClickSound

This Sound object uses a Sound media item and produces a click sound
when it plays. It is used as a button.

m ExitButton

This Picture object uses a Picture media item for an exit button.

m FramedText

This Picture object uses a Picture media item for a frame containing some
text. When the user clicks within the frame, a photograph of a landscape
moves on top of the frame.
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m TeaPicture

This Picture object uses a Picture media item for a photograph of a field of
tea. The user can move the photograph by dragging within the photograph. 

m MarketPicture

This Picture object uses a Picture media item for a photograph of a street
market.

m TeaKeyboard

This Keyboard object defines a set of special keys. When the user presses
one of the special keys, the Keyboard object moves the tea field photograph
to a new position.

Creating the objects BackgroundPicture, ClickSound, ExitButton, and ClickSound

To create these objects all at once, follow these steps:

1 Click the Rajasthan screen in the Screens pane of the Browser miniwindow.

2 Hold down the Shift key and click the objects BackgroundPicture, ClickSound,
ExitButton, and ClickSound in the Objects pane of the Browser miniwindow.

3 Drag the selected objects to Darjeeling in the Screens pane of the Browser miniwindow.

All four objects are duplicated for the Darjeeling screen.

Creating the object FramedText

To create the object FramedText:

m Create an object that uses the media item S5_FRM.PIC, rename the object
FramedText, and reposition its X coordinate to 354 and its Y coordinate to 98.



Creating the object TeaPicture

To create the object TeaPicture:

m Create an object that uses the media item S5_TEA.PIC, rename the object TeaPicture,
and reposition it as shown.
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Creating the object MarketPicture

To create the object MarketPicture, follow these steps:

1 Create an object that uses the media item S5_MRKT.PIC, rename the object
MarketPicture, and reposition it as shown.

2 Choose Parameters from the Edit menu.

3 Click the Enabled checkbox.

The checkbox changes from selected to deselected. 
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Creating the object TeaKeyboard

To create the object TeaKeyboard, follow these steps:

1 Double-click the empty area of the Objects pane of the Browser miniwindow.

Empty 8 appears in the Objects pane of the Browser miniwindow.

Note:  The name of a new Empty object depends on the number of objects
you have already created. For example, the first Empty object you create for a
screen is named Empty 1.

2 Press the object Empty 8 in the Browser miniwindow.

A pop-up menu appears.

3 Choose Keyboard.

The object changes from an Empty object to a Keyboard object. Its name
changes to Keyboard 8.

4 Double-click the object Keyboard 8 in the Objects pane of the Browser miniwindow.

A dialog box appears.

5 Type TeaKeyboard in the Name field.

6 Type 0 in both the Width and Height fields.

The object TeaKeyboard will not need to respond to mouse activity, so it does
not need to occupy any area on the screen. If it did occupy some area of the
screen, it might overlap objects further back in the object layering and prevent
them from detecting mouse activity. Setting the width and height for object
TeaKeyboard to zero ensures that it will not overlap the objects behind it.

Note:  Another way to ensure that an object will not overlap any other objects
is to position the object a considerable distance away from the other objects in
the visible portion of the screen. You can achieve this by setting both the X
and Y coordinate fields of the object to –1000.
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7 Click OK.

Adding interactivity to the Darjeeling screen

When the title is playing, the Darjeeling screen is one of three screens that
the user can view and interact with to obtain more detailed information on
India.

Adding interactivity to the lower-right object ClickSound

Earlier in the chapter you copied the lower-right and the lower-left
ClickSound objects from the Rajasthan screen into the Darjeeling screen. You
need to modify the lower-right copy so that clicking it makes the Rajasthan
screen rather than the Varanasi screen appear. You do not need to modify the
lower-left copy because it behaves the same way in both the Rajasthan and
Darjeeling screens.

To modify the interactivity of the lower-right object ClickSound:

m Change Go To Varanasi to Go To Rajasthan.

Adding interactivity to object FramedText

When the Darjeeling screen appears, the object FramedText will appear.
When the user clicks the object FramedText, the object TeaPicture will center
itself over the object FramedText.

To add interactivity to the object FramedText, follow these steps:

1 Add the Mouse Up event to the object FramedText.

2 Add the Move To command to the Mouse Up event.

Move To Itself 0 0 appears in the Actions pane of the Browser miniwindow.
The Move To command repositions its target object to a specified location.
Initially, the specified location is at X and Y coordinates (0, 0).

You must change the target of the Move To command to the object TeaPicture.
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3 Drag the object TeaPicture in the Objects pane to Move To Itself 0 0 in the Actions pane
of the Browser miniwindow.

Move To Itself 0 0 becomes highlighted as you drag the object over it. This
informs you that object TeaPicture is an acceptable target for this command.
After you release the mouse button, Move To Itself 0 0 changes to Move To
TeaPicture 0 0. 

Because object TeaPicture will reposition itself over the object FramedText,
you need to specify a different location than (0, 0) for this command. You can
use the Info miniwindow to determine the location of object FramedText.

4 Click the Display window.

The Display window becomes the active window.

5 Choose Show Info from the Window menu.

The Info miniwindow appears. 

When the Display window is active, the Info miniwindow shows the position
of the pointer as you move it within the Display window. In addition, it shows
the current position and size of a selected object as you reposition or resize
the object within the Display window.
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6 Move the pointer to the inner top-left corner of the frame presented by object
FramedText.

The Info miniwindow shows X and Y coordinates at approximately 
(361, 105).

7 Double-click Move To TeaPicture 0 0.

A dialog box appears.

8 Type 361 in the X coordinate field and 105 in the Y coordinate field. 

9 Click OK.

Move To TeaPicture 0 0 changes to Move To TeaPicture 361 105.

Adding interactivity to object TeaPicture

When the Darjeeling screen appears, the object TeaPicture will appear. When
the user drags within the object TeaPicture, the object will move with the
pointer.

As you drag the object TeaPicture, you will see how it passes in front of or
behind other objects depending on their relative position in the object
layering. It will appear to pass behind object MarketPicture and in front of
object FramedText. 

To add interactivity to the object TeaPicture, follow these steps:

1 Add the Mouse Moved event to the object TeaPicture.

2 Add Drag Itself to the Mouse Moved event.

Adding interactivity to object TeaKeyboard

When the Darjeeling screen appears, the object TeaKeyboard will be enabled
to detect when the user presses certain keys. When the user presses one of
these keys, the object TeaPicture will move a short distance relative to its
current position. 
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To add interactivity to object TeaKeyboard, follow these steps:

1 Add the Key Down event to the object TeaKeyboard.

The Key Down event appears in the Events pane of the Browser miniwindow.
Initially, the Key Down event is set to detect when the user presses the key for
the letter a. You need to change the key it detects.

2 Double-click Key Down a.

A dialog box appears.

3 Type 8. 

4 Click OK.

Key Down a changes to Key Down 8.

In the next step, you will add a Move By command that repositions an object
a specified distance from its current position. The technique for adding the
Move By command is similar to the technique you learned earlier for adding
the Move To command. 

5 Add Move By TeaPicture 0–5 to Key Down 8.

Move By TeaPicture 0–5 will reposition the target object 5 pixels upward.

6 Click Key Down 8.

7 Choose Copy from the Edit menu.

8 Choose Paste from the Edit menu.

A copy of Key Down 8 appears in the Events pane of the Browser
miniwindow.

9 Change the copy of Key Down 8 to Key Down 6.
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10 Change Move By TeaPicture 0–5 to Move By TeaPicture 5 0 for Key Down 6.

Move By TeaPicture 5 0 will reposition the target object 5 pixels to the right.

11 Click Key Down 8.

12 Choose Copy from the Edit menu.

13 Choose Paste from the Edit menu.

14 Change the copy of Key Down 8 to Key Down 2.

15 Change Move By TeaPicture 0–5 to Move By TeaPicture 0 5 for Key Down 2.

Move By TeaPicture 0 5 will reposition the target object 5 pixels downward.

16 Click Key Down 8.

17 Choose Copy from the Edit menu.

18 Choose Paste from the Edit menu.

19 Change the copy of Key Down 8 to Key Down 4.

20 Change Move By TeaPicture 0–5 to Move By TeaPicture -5 0 for Key Down 4.

Move By TeaPicture–5 0 will reposition the target object 5 pixels to the left.

Save your work now and preview the title if you have not already done so.

Compiling a project using Runtime Maker

Runtime Maker is a compiler you use to convert your project into a stand-
alone title that you can play.

Once you have built your project and previewed it using the Run command,
you save it as a text file that Runtime Maker can compile. The text file is an
Apple Media Language description of your project. Runtime Maker compiles
the Apple Media Language version of a project, not the project itself.
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To compile your project, follow these steps:

1 Choose Runtime Setup from the File menu.

A dialog box appears. The settings in this dialog box control aspects of your
title’s behavior while it is playing. 

Tip:  After you finish this chapter and begin to build other projects, choose
your runtime settings early in the process so that you can preview these
settings while you preview your title.

2 Make the choices in the dialog box as shown.

The width and height settings specify the dimensions of the screens that
appear when your title is playing.

The upper pull-down menus specify whether your title should use 24-bit
color (millions of colors), 16-bit color (thousands of colors), or 8-bit color
(256 colors). Your title will use the first setting you specify that is supported
by the computer on which it is playing.

The lower pull-down menus specify the shape of the pointer under various
circumstances. The first two settings refer to the shape the pointer takes when
it moves over an enabled or disabled area of the screen. The third setting
refers to the shape the pointer takes when your title is loading media from 
the disk.
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The first radio button group specifies the appearance of the picture and text
scrollers. The second radio button group specifies the appearance of the
movie controller.

3 Click OK.

4 Choose Save as Text from the File menu.
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